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FIX: You cannot suspend or terminate service orchestration instances after you incorrectly shut down a BizTalk Server host instance in Microsoft BizTalk Server 2006 R2


View products that this article applies to.

Symptoms

When you try to suspend or terminate some service orchestration instances in BizTalk Server Administration Console of Microsoft BizTalk Server 2006 R2, the service orchestration instances stay in the Active state. Therefore, these service orchestration instances appear unresponsive.

This problem typically occurs after some BizTalk Server host instances are shut down incorrectly. For example, some custom pipeline components that you are using stop responding. If you restart the BizTalk Server process (Btsntsvc.exe) to recover from this, you may experience this issue.

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Cause

This problem occurs because there is a problem in a stored procedure in the BizTalkMsgBoxDB database.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Installation Information

This hotfix updates the BizTalkMsgBoxDB database. To avoid errors and unexpected crashes during the installation of the hotfix, follow these steps:
  1. Stop the SQL Server Agent service that is running the BizTalk SQL Server Agent jobs.
  2. Stop the Internet Information Services (IIS) service to stop all isolated BizTalk host instances.
  3. Stop all BizTalk host instances that are running in the BizTalk group in which you are experiencing the problem.
  4. Apply this hotfix.

Prerequisites

You must have BizTalk Server 2006 R2 installed to apply this hotfix.

Restart requirement

After you install the hotfix, restart the SQL Server Agent service, the IIS service, and the BizTalk host instances.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Msgbox_application_logic.sqlNot applicable529,12803-Jun-200914:42Not applicable
Note Because of file dependencies, the most recent hotfix that contains these files may also contain additional files.

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Workaround

To work around this problem, follow these steps:
  1. Shut down all BizTalk host instances in BizTalk Administration Console.
  2. Shut down IIS on the servers in the BizTalk group in which you are experiencing the problem by running the following command:
    net stop iisadmin /y
  3. Wait five minutes.
  4. In BizTalk Administration Console, suspend or terminate the problematic service orchestration instances.

Notes
  • When you shut down all BizTalk host instances and then let the SQL Server Agent job DeadProcess_Cleanup run for some time, the problematic service orchestration instances return to their usual state. Therefore, you can suspend or terminate those instances.
  • To restart the IIS service, run the following command:
    net start w3svc

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about how to maintain and troubleshoot BizTalk Server databases, click the following article number to view the article in the Microsoft Knowledge Base:
952555 How to maintain and troubleshoot BizTalk Server databases
For more information about how to suspend, resume, and terminate orchestration instances, visit the following MSDN Web site:For more information about service orchestration instance states, visit the following Microsoft TechNet Web site:For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbbiztalk2006r2sp1fix, kbbug, kbexpertiseinter, kbfix, kbhotfixserver, kbqfe, kbbtsadmin, KB969987

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Article Info
Article ID : 969987
Revision : 3
Created on : 7/8/2009
Published on : 7/8/2009
Exists online : False
Views : 429