Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Windows 2003 and Windows XP with LSI MegaRAID controller fails to hibernate under high load and shows error "insufficient system resources to complete the API"


View products that this article applies to.

Source: Microsoft Support

↑ Back to the top


Rapid publishing

RAPID PUBLISHING ARTICLES PROVIDE INFORMATION DIRECTLY FROM WITHIN THE MICROSOFT SUPPORT ORGANIZATION. THE INFORMATION CONTAINED HEREIN IS CREATED IN RESPONSE TO EMERGING OR UNIQUE TOPICS, OR IS INTENDED SUPPLEMENT OTHER KNOWLEDGE BASE INFORMATION.

↑ Back to the top


Action



You use a computer that is running Microsoft Windows XP (x86 or x64 Edition) or Microsoft Windows Server 2003 (x86 or x64 Edition)

You have an LSI MegaRAID with MegaSAS SAS RAID solution installed and the following drivers are installed:
  • megasr.sys (any version)
  • megasas.sys (version 4.7.0 and up)


The boot partition, and therefore the hibernation file, is stored on a volume which resides on a disk which is connected to the RAID controller.

You attempt to initiate hibernation.

↑ Back to the top


Result



The machine fails to hibernate, and you recieve an error message that is similar to the following:

����� "Insufficient System Resources Exist to Complete the API. "

�Hibernation becomes disabled and remains disabled until the computer is restarted.

↑ Back to the top


Cause



This problem occurs because of a known issue with the�operating system and certain LSI SAS RAID drivers. The issue�typically occurs in the following conditions:
  • The machine has 1 gigabyte (GB) of RAM.
  • Processes are stressing the computer at the time when hibernation is attempted.
  • You have already hibernated and resumed the computer several times.


This issue occurs when the kernel power manager cannot allocate the contiguous physical memory needed to prepare the system to hibernate.� A portion of the memory is used to store configuration information for the RAID drivers in use, which can vary depending on the requirements of the RAID driver.� The amount of physical memory which is needed to store this data may not be available when hibernation is attempted under these conditions.� If the amount of physical memory is not available, then hibernation will fail and return this error message.

↑ Back to the top


Resolution



Once hibernation has failed, the machine must be shut down and restarted to re-enable hibernation.� Additionally, these workarounds may help in preventing this issue:

1. Reducing the stress on the computer by closing programs before attempting to hibernate

2. Increasing the amount of physical memory in the machine

↑ Back to the top


More information



There are several other issues with the operating systems listed in the "Applies To" section which can also cause hibernation problems with a similar error, which have been resolved in the latest service packs. For further information please see:

KB 330909: Hibernation problem on computers with 1 GB of RAM

KB 909095: The computer occasionally does not hibernate and you receive an "Insufficient System Resources Exist to Complete the API" error message in Windows XP with Service Pack 2, in Windows XP Tablet PC Edition 2005, or in Windows XP Media Center Edition 2005

↑ Back to the top


Disclaimer

MICROSOFT AND/OR ITS SUPPLIERS MAKE NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY, RELIABILITY OR ACCURACY OF THE INFORMATION CONTAINED IN THE DOCUMENTS AND RELATED GRAPHICS PUBLISHED ON THIS WEBSITE (THE �MATERIALS�) FOR ANY PURPOSE. THE MATERIALS MAY INCLUDE TECHNICAL INACCURACIES OR TYPOGRAPHICAL ERRORS AND MAY BE REVISED AT ANY TIME WITHOUT NOTICE.

TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, MICROSOFT AND/OR ITS SUPPLIERS DISCLAIM AND EXCLUDE ALL REPRESENTATIONS, WARRANTIES, AND CONDITIONS WHETHER EXPRESS, IMPLIED OR STATUTORY, INCLUDING BUT NOT LIMITED TO REPRESENTATIONS, WARRANTIES, OR CONDITIONS OF TITLE, NON INFRINGEMENT, SATISFACTORY CONDITION OR QUALITY, MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE, WITH RESPECT TO THE MATERIALS.

↑ Back to the top


Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

↑ Back to the top


Keywords: kbnosurvey, kbarchive, kbrapidpub, kbnomt, KB969909

↑ Back to the top

Article Info
Article ID : 969909
Revision : 2
Created on : 1/15/2015
Published on : 1/15/2015
Exists online : False
Views : 255