Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You cannot connect to an Internet printer if the Internet Printing Client is disabled or if the Internet Printing Client has recently been enabled and the Print Spooler has not restarted


View products that this article applies to.

Symptoms

On a computer that is running Windows Vista or a later version of Windows, when you try to establish a connection to an Internet printer, you may receive an error message that resembles the following:
Windows cannot connect to the printer. Check the printer name and try again. If this is a network printer, make sure that the printer is turned on, and that the printer address is correct.

↑ Back to the top


Cause

This problem may occur if the Internet Printing Client feature is disabled on the computer. This problem may also occur if the Internet Printing Client has recently been enabled and the Print Spooler service has not restarted.

To have us fix this problem for you, go to the "Fix it for me" section. If you would rather fix this problem yourself, go to the "Let me fix it myself" section.

↑ Back to the top


Fix it for me

To fix this problem automatically, click the Fix this problem link. Then, click Run now button from the Automated Troubleshooting Services page and follow the steps in this wizard.

↑ Back to the top


Let me fix it myself

To resolve this problem yourself, restart the Print Spooler service after you enable the Internet Printing Client feature.
  1. Enable the Internet Printing Client feature on the computer. To do this, follow these steps:
    1. Click StartStart button , type Programs and Features in the Start Search box, and then press ENTER.
    2. Click Turn Windows features on or off.
    3. In the Windows Features dialog box, expand Print Services, click to select the Internet Printing Client check box, and then click OK.
  2. Restart the computer or restart the Print Spooler service. To restart the Print Spooler service, follow these steps:
    1. Click StartStart button , type Administrative Tools in the Start Search box, and then press ENTER.
    2. Double-click Services.
    3. Right-click Print Spooler, and then click Restart.
  3. Try to install the Internet printer again.

For troubleshooting steps and an automatic fix for common printer problems in Windows, please see the following Microsoft web page:


Troubleshooter: Printer problems in Windows


↑ Back to the top


Keywords: kb, kbfixme, kbmatsfixme, kbexpertisebeginner, kbtshoot, kbsurveynew, kbprb

↑ Back to the top

Article Info
Article ID : 969708
Revision : 3
Created on : 4/17/2018
Published on : 4/17/2018
Exists online : False
Views : 362