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When you use the Windows Key+L keyboard sequence to lock a Windows XP-based computer shortly after you log on to the system, the operating system may be automatically unlocked and the desktop can be accessed


View products that this article applies to.

Symptoms

In the network environment, you enable synchronous processing of logon scripts in a Group Policy object (GPO).
Consider the following scenario, you log on to a Windows XP-based computer. Then, within 1 or 2 seconds, you press the Windows Key+L keyboard sequence to lock the computer. In this scenario, the operating system may automatically unlock. This enables the desktop to be accessed. When the desktop can be accessed, all usual actions can be performed in the previously locked user session.

When this problem occurs, if you press Windows Key+L again, nothing happens and the user session remains open. Then, if you press CTRL+ALT+DEL, you receive a message box for the user's credentials.

If you enable the Fast Logon Optimization feature, this problem occurs.

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Cause

This problem occurs because synchronous processing of logon scripts requires Windows to switch to the user desktop. This is because a script may start a program that requires user input. However, the operating system does not check whether the user has already locked the desktop before the operating system displays the desktop.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows XP Service Pack 2 or a later service pack installed on the computer.For more information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP with Service Pack 2, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Koc.dll5.1.2600.35478,19202-Apr-200915:06x86SP2
Licdll.dll5.1.2600.3547423,93602-Apr-200912:36x86SP2
Winlogon.exe5.1.2600.3547507,39202-Apr-200913:33x86SP2
Windows XP with Service Pack 3, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Licdll.dll5.1.2600.5788423,93602-Apr-200915:21x86SP3
Winlogon.exe5.1.2600.5788509,44002-Apr-200914:56x86SP3
Dpcdll.dll5.1.2600.5788104,96002-Apr-200914:54x86SP3
Dpcdll.dll5.1.2600.5788104,44802-Apr-200915:21x86SP3

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Workaround

To work around this problem, enable the "Always wait for the network at computer startup and logon" policy.

You can locate the policy in the following location:

Computer Configuration\Administrative Templates\System\Logon\

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

305293 Description of the Windows XP Professional Fast Logon Optimization feature


For more information about the Fast Logon Optimization feature, visit the following Web site:

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Keywords: kb, kbautohotfix, kbexpertiseinter, kbfix, kbbug, kbsurveynew, kbqfe, kbhotfixserver

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Article Info
Article ID : 969557
Revision : 4
Created on : 3/30/2017
Published on : 3/30/2017
Exists online : False
Views : 366