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A Stop error occurs on an HP ProLiant server that has the firmware from an E200/E200i HP Smart Array SAS/SATA controller installed on any Windows Server platform


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Symptoms

On an HP ProLiant server that has firmware from an E200/E200i HP Smart Array SAS/SATA controller installed on any Windows Server platform, you encounter a Stop error that resembles one of the following.

Errors on the Windows Server x86 (32 bit) platform

Error message 1
STOP: 0x0000000A ( 00000000, d000001b, 00000001, 8083dbcc )
Error message 2
STOP: 0x0000007E ( c0000005, 8081c6fd, b71aebd8, b71ae8d4 )
Error message 3
STOP: 0x0000008E ( c0000005, 809366ba, b825cc84, 00000000 )
Error message 4
STOP: 0x000000D0 ( 00000008, d0000002, 00000000, 80893aaf )
Error message 5
STOP: 0x000000D1 ( ffffff9e, d0000002, 00000000, b9515900 )

Errors on the Windows Server x64 (64 bit) platform

Error message 1
STOP: 0x0000000A ( 0000001c, 00000002, 00000001, fffff800010f1c8f )
Error message 2
STOP: 0x000000C5 ( 00000000, 00000002, 00000001, fffff800011a9eba )
Additionally, you may also receive a Stop error message that resembles one of the following.

Error message 1
STOP: 0x00000024 ( parameter1 , parameter2 , parameter3 , parameter4 )
Error message 2
STOP: 0x00000050 ( parameter1 , parameter2 , parameter3 , parameter4 )
Error message 3
STOP: 0x0000004E ( parameter1 , parameter2 , parameter3 , parameter4 )
You may experience this problem on the following HP ProLiant servers that are configured to use the E200/E200i HP Smart Array SAS/SATA controller:
  • HP ProLiant BL460c
  • HP ProLiant DL360 G5
  • HP ProLiant DL580 G5
  • HP ProLiant ML370 G5

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Cause

This issue occurs because HP Insights agents use a special IO Control (IOCTL) mechanism that relies on the firmware. The firmware that is listed in the "Symptoms" section was found to be faulty when the IOCTL buffer spanned a 16-megabyte (MB) boundary (involving requests from HP Drive Array Info and Fiber Array agents). The resulting memory corruption consists of an area of memory that has been zeroed. This corruption always occurs at a multiple of 16 MB in the physical memory. In the system space, the zeroed area is always located at a page boundary, and it is usually in the nonpaged pool area. However, other system areas may also be affected.

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Resolution

To prevent this issue, upgrade the Smart Array Controller firmware to version 1.82 (or a later version) by following these steps:
  1. Visit the following HP Web site:
  2. In the For product field, enter HP Smart Array E200.
  3. Select the appropriate Smart Array E200 controller model.
  4. Select the appropriate operating system.
  5. Select the Firmware - Storage Controller category.
  6. Click Download next to the following description:
    HP Smart Array E200 Firmware Version 1.82 (or a later version)
Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

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More information

HP has published the following Customer Advisory for this problem: Note This issue typically occurs on Windows Server 2003 platforms. However, all Windows Server platforms that use the E200/E200i SAS/SATA controller may be affected.

HP found this issue in the E200/E200i array controller firmware. In response, the company released a new version of this firmware, version 1.82. Version 1.82 was released in two sub-versions:
  • The Windows sub-version: For all Windows operating systems that are running on HP ProLiant platforms that include the E200/E200i controller, visit the following HP Web site:Note In compliance with the information in Microsoft Knowledge Base (KB) article 940015, we recommend that you install or update the following drivers for Windows Server 2003 on the same HP ProLiant platforms:
    • Storport.sys from KB article 950903 ( version 5.2.3790.4368, date 4-Sep-2008) or a later version
    • Hpcisss2.sys available from HP ( version 6.14.0.32/64, date 7-Jan-2009) or a later version
    The new E200/E200i firmware version 1.82 was extensively tested by using these versions of Storport.sys and Hpcisss2.sys.
  • The Linux sub-version: For all Linux operating systems that are running on HP ProLiant platforms that include the E200/E200i controller, visit the following HP Web site:Computer configurations that apply to the Linux sub-version:
    • Windows virtual machines
    • Systems in a virtualization environment (for example, VMWare)
    • Systems that are based on Linux
    • HP ProLiant platforms that include the E200/E200i controller
    Notes
    • For all configurations, including the E200/E200i controller, contact HP to apply this firmware update.
    • This issue may occur in all versions of the firmware since the E200/E200i HP Smart Array SAS/SATA controller was released. This issue is related to the issue that is described in KB article 940015, and it concerns the same HP ProLiant platforms. Although KB article 940015 addresses an interoperability problem between the Hpcisss2.sys and Storport.sys drivers, the issue that is addressed here is located in the ES200/ES200i controller firmware. Most of the symptoms that are described in KB article 940015 are fixed by updating the Hpcisss2.sys and Storport.sys drivers. However, some of these issues are now also resolved by updating the firmware for the E200/E200i HP Smart Array SAS/SATA controller.

      For more information, click the following article number to view the article in the Microsoft Knowledge Base:
      940015 You receive a Stop error message after you install update 932755 or 941276 on an HP ProLiant server that is running Storport in Windows Server 2003
    • To obtain the current version of the firmware of the HP Smart Array, use the Array Configuration Utility (ACU) tool that is provided by HP. This tool is installed with all HP Smart Array products and is used to display current configuration and to upgrade firmware on the adapters.
Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

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References

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
940015 You receive a Stop error message after you install update 932755 or 941276 on an HP ProLiant server that is running Storport in Windows Server 2003

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Keywords: kberrmsg, kbtshoot, kbexpertiseinter, kbsurveynew, kbprb, KB969550

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Article Info
Article ID : 969550
Revision : 4
Created on : 10/20/2011
Published on : 10/20/2011
Exists online : False
Views : 679