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Users cannot perform authentication through ADFS in a Windows Server 2003 R2 environment when the UPN suffixes contain a character that expands to a two-letter pair


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You establish an Active Directory Federation Services (ADFS) environment on a Windows Server 2003 R2-based server.
  • One of the following languages is configured on the resource server in the ADFS environment:
    • Bokmal
    • Croatian
    • Czech
    • Danish
    • Hungarian
    • Nynorsk
    • Slovak
    • Spanish
    • Vietnamese
  • The user principal name (UPN) suffixes for some users contain a character that expands to a two-letter pair. For example, the UPN suffix contains the character �, and this expands to the two-letter pair aa.
In this scenario, these users cannot perform authentication through ADFS.

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Cause

This issue occurs because ADFS uses the string comparator incorrectly when it tries to sort and search UPN suffixes.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, the computer must have Windows Server 2003 R2 Service Pack 2 (SP2) installed.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 R2 SP2, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Adfsreg.exe5.2.3790.44827,68024-Mar-200912:56x86SP2
System.web.security.singlesignon.dll5.2.3790.4482581,63224-Mar-200917:42x86SP2
Windows Server 2003 R2 SP2, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Adfsreg.exe5.2.3790.44829,21624-Mar-200915:33x64SP2
System.web.security.singlesignon.dll5.2.3790.4482581,63224-Mar-200915:33x86SP2

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about ADFS, visit the following Microsoft Web site: To configure a language on the resource server, follow these steps:
  1. Open the Regional and Language Options item. To do this, click Start, click Run, type intl.cpl in the Open box, and then click OK.
  2. Under Standards and formats, select one of languages that are mentioned in the "Symptoms" section, such as Danish.
  3. On the Languages tab, click Details.
  4. Under Installed services, click Add, and then select the language that you specified in step 2.
  5. Under Default input language, select the added language, and then click OK.
  6. On the Advanced tab, click to select the Apply all settings to the current user account and to the default user profile check box under Default user account settings.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbexpertiseadvanced, kbfix, kbsurveynew, kbqfe, KB969451

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Article Info
Article ID : 969451
Revision : 2
Created on : 10/7/2011
Published on : 10/7/2011
Exists online : False
Views : 313