Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

RPC 0x800706ba and 0x800706bf errors occur when backup software tries to create VSS shadow copies on a computer that is running Windows Server 2003 SP2


View products that this article applies to.

Symptoms

On a computer that is running Windows Server 2003 Service Pack 2, the following backup software remote procedure call (RPC) errors occur when the software tries to create Volume Shadow Copy Service (VSS) shadow copies on the computer:
  • 0x800706ba
  • 0x800706bf

↑ Back to the top


Cause

VSS begins to shut down after VSS has been idle for three minutes. When VSS is shutting down, VSS does not correctly reject COM-related requests. Because of this behavior, various VSS APIs are invoked while VSS is shutting down. This behavior causes RPC time-out errors.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, the computer must have Windows Server 2003 Service Pack 2 installed.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Server 2003 SP2, x86-based versions

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Swprv.dll5.2.3790.4479288,25620-Mar-200914:52x86SP2
Vssapi.dll5.2.3790.4479570,88020-Mar-200914:52x86SP2
Vssvc.exe5.2.3790.4479838,65620-Mar-200911:05x86SP2

Windows Server 2003 SP2, Itanium-based versions

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Swprv.dll5.2.3790.4479871,93620-Mar-200913:02IA-64SP2Not Applicable
Vssapi.dll5.2.3790.44791,670,14420-Mar-200913:02IA-64SP2Not Applicable
Vssvc.exe5.2.3790.44792,595,84020-Mar-200913:02IA-64SP2Not Applicable
Wvssapi.dll5.2.3790.4479570,88020-Mar-200913:02x86SP2WOW

Windows Server 2003 SP2 and Windows XP SP2, x64-based versions

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Swprv.dll5.2.3790.4479693,76020-Mar-200913:06x64SP2Not Applicable
Vssapi.dll5.2.3790.44791,345,02420-Mar-200913:06x64SP2Not Applicable
Vssvc.exe5.2.3790.44792,068,99220-Mar-200913:06x64SP2Not Applicable
Wvssapi.dll5.2.3790.4479570,88020-Mar-200913:06x86SP2WOW

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about how to enable VSS debug tracing , click the following article number to view the article in the Microsoft Knowledge Base:
887013 � How to enable the Volume Shadow Copy service's debug tracing features in Microsoft Windows Server 2003
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbautohotfix, kbexpertiseadvanced, kbfix, kbsurveynew, kbqfe, kbhotfixserver, KB969219

↑ Back to the top

Article Info
Article ID : 969219
Revision : 1
Created on : 4/13/2009
Published on : 4/13/2009
Exists online : False
Views : 274