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Unable to select disk from dropdown in Cluster Administrator


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Source: Microsoft Support

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Symptom



When you are creating a new Physical Disk resource through the Cluster Administrator console, you may notice it is not listing the newly added drives in Physical Disk new resource wizard.

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Cause



Whereas this issue may be tied to the storage drivers not detecting the newly added disk without a restart, current vendor device drivers and service packs for Windows 2000 and 2003 seem to address these issues.



Another possible cause may be result of how you have connected to the Cluster through Cluster Administrator. In Windows Server 2003, we recommend that you present a new disk to a single node at first and then add it as a cluster resource. If Cluster administrator is connected to a different node, then you will not see the newly added disk.

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Resolution



NOTE: The steps of creating a disk and presenting it to the OS will be vendor specific. Please contact your storage vendor on any specific steps that must be taken to create and configure a new disk within the storage device for Microsoft Failover Clustering in Windows 2000 and 2003. This may require specific drivers and firmware versions based on the server�s Windows version and service pack level.



The following steps presume a multimode cluster and that the newly created disk will be presented to Node1 first. References to Node1 in this article can be any node that you want, assuming it will have access to the shared storage. Just make sure that you remain consistent as you follow the steps.



1.�������� Make Node1 the passive node by moving all groups to another node.

2.�������� In Cluster administrator, right-click Node1 and select PAUSE.

3.�������� Perform the Storage vendor specific steps to create a new logical disk for use by Windows 2000/2003. As soon as it is created, present the LUN to ONLY NODE1.



NOTE: At This Point the disk is not managed by cluster. If this new disk is presented to multiple cluster nodes before it is controlled by Cluster Service unexpected results can occur including corruption.



4.�������� If the device drivers providing connectivity to the storage allow for, perform a bus rescan.

For example: the Emulex HBAnywhere utility has an option to perform a Bus rescan to locate newly added devices on the fibre.



5.�������� Open disk management to confirm that the new disk is available.



NOTE: If the disk does not appear after you use the vendor utilities to rescan the storage path then a restart of the node will be needed at this point.



6.�������� Start Disk management, create a new partition on the new disk and format it as NTFS.



NOTE: Make Sure That the new disk remains a Basic disk.



7.�������� Select Start / Run and type �CluAdmin <Node1ServerName>"



NOTE: Make Sure That You use node1�s server name as this is the only server that is aware of the new disk.



8.�������� In Cluster Administrator, Right-Click Node1 and select RESUME.



9.�������� Create a new group in Cluster Administrator by Selecting File, New, Group. Call it 'New Disk Group' or something unique to the cluster. Select Finish.



10.������� Move the group to Node1 if not already present



11.������� Create a new physical disk resource and assign it to 'New Disk Group' by doing the following:



����a.�������� In Cluster Administrator, select File, New, Resource.

����b.�������� Give it a Name and description appropriate for the disk. Change the resource type to "Physical Disk" and select the appropriate group from the list.

����c.��������� Select Next.

����d.�������� Make sure each nodes is included as a possible owner.

����e.�������� Select Next.

����f.��������������������� No dependencies are needed, select Next.

����g.�������� On the screen titled "Disk parameters" select the new disk from the drop-down list.

����h.�������� Select finish



NOTE: If the new disk is not displayed in the drop-down list of available Physical Disk resources then try the alternative method in this article:



12.������� Bring the disk online. If it fails, troubleshoot based on errors found in the System log and the Cluster Log.



13.������� As soon as the disk is verified successfully on Node1, the LUN representing this logical disk is ready to be presented to the other nodes through hardware utilities.



NOTE: You should see the new disk immediately in Device Manager. If not then a restart may be needed� so that the drivers can appropriately present the new disk to Windows.



Alternative Method



If you have followed the previous steps and do not see the newly created disk in the drop-down for the new resource wizard, you can try the following to force creating the disk as a cluster resource.



Note: This will not create a working resource if the disk is not being presented correctly by the storage. If you continue to have problems, you should follow up with your storage vendor to make sure that you have a suitable configuration.



The following commands create a disk resource. Replace the "Disk F:" with the desired disk resource name, the "Cluster group" with the desired group name, and the signature with that of your new disk.



1.�������� The following command will create a resource of type physical disk:



��������������������cluster res "Disk F:" /Create /group:"Cluster Group" /Type:"physical disk"



2.�������� The next command is needed for associating the disk through its disk signature to the physical disk resource.



NOTE: There are different syntaxs that achieve the same goal . Select the command, depending on the operating system that is used.



��������������� Using decimal value for Windows 2000, 2003 and 2003 R2



����������������������������cluster res "Disk F:" /priv signature=1405929673



����������� Using hexadecimal value for Windows 2000 and 2003.



����������������������������cluster res "Disk F:" /priv signature=0x53CCC8C9



��������

����������� Using Drive letter with Windows 2000 and 2003:

����������������������������cluster res "Disk F:" /priv Drive="F:"



����������� Using Drive letter with Windows Server 2003 R2:

����������������������������cluster res "Disk F:" /priv Disk="F:"



The signature and drive letter are obtained from HKLM/System/MountedDevices of Node1

� �

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More information



Additional Links:



304736 How to Extend the Partition of a Cluster Shared Disk

http://support.microsoft.com/?id=304736



929275 A new disk resource from a SAN or from an iSCSI storage device does not

appear in the Disk list on a Windows Server 2003-based server cluster

http://support.microsoft.com/default.aspx?scid=kb;EN-US;929275

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Keywords: KB969053, kbnomt, kbrapidpub

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Article Info
Article ID : 969053
Revision : 1
Created on : 3/13/2009
Published on : 3/13/2009
Exists online : False
Views : 318