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The Tcpipv6.sys driver stops responding to any TCP/IPv6 requests on a Windows Server 2003 SP2-based computer when the driver binds to many network adapters


View products that this article applies to.

Symptoms

When TCP/IPv6 is installed on a Windows Server 2003 SP2-based computer, the Tcpipv6.sys driver becomes deadlocked. Additionally, the driver stops responding to any TCP/IPv6 requests. This problem occurs when TCP/IPv6 is bound to many network adapters (such as 24 adapters) in a short time. When this problem occurs, function failures or exceptions also occur on any applications or services that rely on TCP/IPv6. Eventually, the computer may stop responding (hang).

Note This issue does not occur for the TCP/IPv4 protocol.

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Cause

This issue occurs because the tcpipv6.sys driver uses the critical worker queue to submit object identifiers (OIDs) to network miniport drivers. If the tcpipv6.sys driver binds to too many adapters in a short time, these resources become exhausted quickly. Therefore, a deadlock occurs.

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Resolution

Hotfix information for Windows Server 2003

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, the computer must run Windows Server 2003 Service Pack 2.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

Registry information

To use this hotfix, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 Service Pack 2, x86-based
File nameFile versionFile sizeDateTimePlatform
Tcpip6.sys5.2.3790.4480235,00821-Mar-200914:08Not Applicable
Windows Server 2003 Service Pack 2, x64-based version
File nameFile versionFile sizeDateTimePlatform
Tcpip6.sys5.2.3790.4480376,96022-Mar-200915:22x64
Windows Server 2003 Service Pack 2, Itanium-based version
File nameFile versionFile sizeDateTimePlatform
Tcpip6.sys5.2.3790.4480765,95222-Mar-200915:18Not Applicable

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbexpertiseadvanced, kbfix, kbsurveynew, kbqfe, KB968597

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Article Info
Article ID : 968597
Revision : 2
Created on : 10/7/2011
Published on : 10/7/2011
Exists online : False
Views : 256