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A handle leak occurs in the print spooler service after you resubmit a print job to a shared printer on which the "Keep printed documents" option is enabled


View products that this article applies to.

Symptoms

Consider the following scenario:
  • A printer is shared on a computer that is running one of the following:
    • Windows XP
    • Windows Server 2003
    • Windows Vista
    • Windows Server 2008
  • The "Keep printed documents" option is enabled in the Properties dialog box of the shared printer.
  • Some print jobs stay in the print queue after they are printed.
  • You right-click one of the print jobs and then click Restart to resubmit the print job.
In this scenario, the handle count of the print spooler service increases by 1. If the print queue is under heavy stress, the handle count of the print spooler service keeps increasing. Finally, the system may stop responding or crash. Or, another unexpected behavior may occur because the resources are exhausted.

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Cause

When a print job is restarted in a print queue, the print spooler service has to create a new EVENT object for synchronization purposes. However, the print spooler service cannot release a previously created EVENT object before the service creates the new EVENT object. Therefore, a handle leak occurs in the print spooler service.

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Resolution

Hotfix information for Windows XP

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

Note You must have a Visual Studio license agreement to obtain this hotfix.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To apply this hotfix, the computer must have Windows XP Service Pack 3 installed.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

Registry information

To use this hotfix, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP SP3, x86-based version
File nameFile versionFile sizeDateTimePlatform
Localspl.dll5.1.2600.5830346,11217-Jun-200910:55x86

Hotfix information for Windows Server 2003

A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To apply this hotfix, the computer must have Windows Server 2003 Service Pack 1 or Service Pack 2 installed.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

Registry information

To use this hotfix, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 SP1, x86-based version
File nameFile versionFile sizeDateTimePlatform
Localspl.dll5.2.3790.3305349,18405-Mar-200914:44x86
Windows Server 2003 SP2, x86-based version
File nameFile versionFile sizeDateTimePlatform
Localspl.dll5.2.3790.4471342,52805-Mar-200914:30x86
Windows Server 2003 SP1, Itanium-based version
File nameFile versionFile sizeDateTimePlatform
Localspl.dll5.2.3790.3305969,72805-Mar-200912:34IA-64
Windows Server 2003 SP2, Itanium-based version
File nameFile versionFile sizeDateTimePlatform
Localspl.dll5.2.3790.4471970,24005-Mar-200912:39IA-64
Windows Server 2003 and Windows XP, x64-based version
File nameFile versionFile sizeDateTimePlatform
Localspl.dll5.2.3790.3305751,61605-Mar-200912:34x64
Windows Server 2003 SP2 and Windows XP SP2, x64-based version
File nameFile versionFile sizeDateTimePlatform
Localspl.dll5.2.3790.4471750,59205-Mar-200912:43x64

Hotfix information for Windows Vista and Windows Server 2008

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Prerequisites

To apply this hotfix, the computer must run one of the following:
  • Windows Vista Service Pack 1
  • Windows Vista Service Pack 2
  • Windows Server 2008
  • Windows Server 2008 Service Pack 2

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

Registry information

To use this hotfix, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Server 2008 and Windows Vista file information note


The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separatelyMUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files (attributes not listed) are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008 and Windows Vista
File nameFile versionFile sizeDateTimePlatform
Localspl.dll6.0.6001.22453636,92818-Jun-200912:01x86
Localspl.dll6.0.6002.22154623,61618-Jun-200911:44x86
For all supported x64-based versions of Windows Server 2008 and Windows Vista
File nameFile versionFile sizeDateTimePlatform
Localspl.dll6.0.6001.22453792,06418-Jun-200912:17x64
Localspl.dll6.0.6002.22154772,60818-Jun-200911:39x64
For all supported Itanium-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Localspl.dll6.0.6001.224531,623,55218-Jun-200911:49IA-64
Localspl.dll6.0.6002.221541,623,55218-Jun-200911:42IA-64

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Workaround

To work around the issue, do not use the "Keep printed documents" option.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information for Windows Server 2008 and Windows Vista

Additional files for all supported x86-based versions of Windows Server 2008 and Windows Vista
File nameFile versionFile sizeDateTimePlatform
Package_for_kb968585_client_1~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,36722-Jun-200905:00Not Applicable
Package_for_kb968585_client_2~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,69322-Jun-200905:00Not Applicable
Package_for_kb968585_client~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,71322-Jun-200905:00Not Applicable
Package_for_kb968585_sc_0~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,40822-Jun-200905:00Not Applicable
Package_for_kb968585_sc_1~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,69022-Jun-200905:00Not Applicable
Package_for_kb968585_sc~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,70122-Jun-200905:00Not Applicable
Package_for_kb968585_server_0~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,42522-Jun-200905:00Not Applicable
Package_for_kb968585_server_1~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,69422-Jun-200905:00Not Applicable
Package_for_kb968585_server~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,71322-Jun-200905:00Not Applicable
X86_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.0.6001.22453_none_3071f1baabf187d4.manifestNot Applicable14,44218-Jun-200919:56Not Applicable
X86_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.0.6002.22154_none_325963eca916f64f.manifestNot Applicable14,42318-Jun-200919:24Not Applicable
Additional files for all supported x64-based versions of Windows Server 2008 and Windows Vista
File nameFile versionFile sizeDateTimePlatform
Amd64_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.0.6001.22453_none_8c908d3e644ef90a.manifestNot Applicable14,51220-Jun-200919:29Not Applicable
Amd64_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.0.6002.22154_none_8e77ff7061746785.manifestNot Applicable14,49318-Jun-200921:46Not Applicable
Package_for_kb968585_client_1~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,37522-Jun-200905:01Not Applicable
Package_for_kb968585_client_2~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,70522-Jun-200905:01Not Applicable
Package_for_kb968585_client~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,72322-Jun-200905:01Not Applicable
Package_for_kb968585_sc_0~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,41622-Jun-200905:01Not Applicable
Package_for_kb968585_sc_1~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,70222-Jun-200905:01Not Applicable
Package_for_kb968585_sc~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,71122-Jun-200905:01Not Applicable
Package_for_kb968585_server_0~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,43322-Jun-200905:01Not Applicable
Package_for_kb968585_server_1~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,70622-Jun-200905:01Not Applicable
Package_for_kb968585_server~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,72322-Jun-200905:01Not Applicable
Additional files for all supported Itanium-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Ia64_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.0.6001.22453_none_307395b0abef90d0.manifestNot Applicable14,45819-Jun-200902:42Not Applicable
Ia64_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.0.6002.22154_none_325b07e2a914ff4b.manifestNot Applicable14,45818-Jun-200921:30Not Applicable
Package_for_kb968585_server_0~31bf3856ad364e35~ia64~~6.0.1.0.mumNot Applicable1,42922-Jun-200905:00Not Applicable
Package_for_kb968585_server_1~31bf3856ad364e35~ia64~~6.0.1.0.mumNot Applicable1,37022-Jun-200905:00Not Applicable
Package_for_kb968585_server~31bf3856ad364e35~ia64~~6.0.1.0.mumNot Applicable1,71622-Jun-200905:00Not Applicable

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Keywords: kbautohotfix, kbexpertiseadvanced, kbfix, kbsurveynew, kbqfe, KB968585

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Article Info
Article ID : 968585
Revision : 3
Created on : 10/7/2011
Published on : 10/7/2011
Exists online : False
Views : 294