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Stop error message when you enable File Server Resource Manager quota management on an NTFS volume on a Windows Server 2003 R2-based computer: "Stop 0x0000007E"


View products that this article applies to.

Symptoms

Consider the following scenario:
  • On a Windows Server 2003 R2-based computer, you enable File Server Resource Manager (FSRM) quota management on an NTFS volume.
  • You apply NTFS compression to the NTFS volume or to a folder on the NTFS volume. Or, sparse files are saved in the NTFS volume.
In this scenario, the computer may restart unexpectedly. Additionally, you may receive the following Stop error message:
Stop 0x0000007E (parameter1, parameter2, parameter3, parameter4)
SYSTEM_THREAD_EXCEPTION_NOT_HANDLED
Notes
  • The parameters in this error message may vary, depending on the actual configuration.
  • Not all "0x0000007E" Stop errors are caused by this problem.

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Cause

This problem occurs because of a timing issue in the Quota.sys driver. When the timing issue occurs, the Quota.sys driver tries to free a memory structure that is not valid. Therefore, the system triggers a Stop error.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, the computer must have Windows Server 2003 Service Pack 1 (SP1) or Windows Server 2003 Service Pack 2 (SP2) installed.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 SP1, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Quota.sys5.2.3790.331389,60024-Mar-200913:34x86
Windows Server 2003 SP2, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Quota.sys5.2.3790.448289,60024-Mar-200913:14x86
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Quota.sys5.2.3790.3313133,12024-Mar-200915:36x64
Windows Server 2003 SP2, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Quota.sys5.2.3790.4482133,12024-Mar-200915:47x64

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Workaround

To work around this problem, remove the FSRM quota, or do not compress the files.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbexpertiseadvanced, kbfix, kbsurveynew, kbqfe, KB968451

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Article Info
Article ID : 968451
Revision : 2
Created on : 10/7/2011
Published on : 10/7/2011
Exists online : False
Views : 347