Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You cannot use a mouse to select combo box items in a RemoteApp program that you connect to through Remote Desktop Connection (RDC) 6.1


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have Remote Desktop Connection (RDC) 6.1 installed on a client computer that is running one of the following operating systems:
    • Windows Server 2008
    • Windows Vista
    • Windows XP
  • On the client computer, you connect to a RemoteApp program through an RDC session.
  • You use a mouse to select an item from a combo box in the RemoteApp program.
In this scenario, when you close the combo box, the item that is displayed in the combo box remains the same. However, you expect the item to change to the item that you selected.

Notes
  • This issue does not occur in a full RDC session.
  • This issue does not occur if you use RDC 6.0.

↑ Back to the top


Cause

This issue occurs because of a design change in RDC 6.1. This design change is included in the following:
  • Hotfix 951616
  • Windows Server 2008
  • Windows XP Service Pack 3
  • Windows Vista Service Pack 1
  • Windows Vista Service Pack 2
  • Windows Server 2008 Service Pack 2

↑ Back to the top


Resolution

Hotfix information for Windows Vista and for Windows Server 2008

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Important Windows Vista and Windows Server 2008 hotfixes are included in the same packages. However, only one of these products may be listed on the �Hotfix Request� page. To request the hotfix package that applies to both Windows Vista and Windows Server 2008, just select the product that is listed on the page.

Prerequisites

To apply this hotfix, the computer must run one of the following:
  • Windows Vista Service Pack 1
  • Windows Vista Service Pack 2
  • Windows Server 2008
  • Windows Server 2008 Service Pack 2

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2008 and Windows Vista file information note

The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files (attributes not listed) are signed with a Microsoft digital signature.

For all supported x86-based versions of Windows Server 2008 and Windows Vista
File nameFile versionFile sizeDateTimePlatformSP requirement
Aaclient.dll6.0.6001.22435136,19218-May-200913:47x86SP1
Aaclient.mofNot Applicable1,09701-Apr-200918:53Not ApplicableSP1
Mstscax.dll6.0.6001.224352,062,33618-May-200913:50x86SP1
Mstscax.mofNot Applicable1,96701-Apr-200918:54Not ApplicableSP1
Tsgqec.dll6.0.6001.2243553,24818-May-200913:52x86SP1
Aaclient.dll6.0.6002.22138136,19218-May-200913:43x86SP2
Aaclient.mofNot Applicable1,09703-Apr-200920:41Not ApplicableSP2
Mstscax.dll6.0.6002.221382,066,43218-May-200913:44x86SP2
Mstscax.mofNot Applicable1,96703-Apr-200920:42Not ApplicableSP2
Tsgqec.dll6.0.6002.2213853,24818-May-200911:53x86SP2
For all supported Itanium-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatformSP requirement
Aaclient.dll6.0.6001.22435298,49618-May-200913:37IA-64SP1
Aaclient.mofNot Applicable1,09701-Apr-200915:54Not ApplicableSP1
Mstscax.dll6.0.6001.224354,928,51218-May-200913:41IA-64SP1
Mstscax.mofNot Applicable1,96701-Apr-200915:56Not ApplicableSP1
Tsgqec.dll6.0.6001.2243580,38418-May-200913:42IA-64SP1
Aaclient.dll6.0.6002.22138298,49618-May-200913:33IA-64SP2
Aaclient.mofNot Applicable1,09703-Apr-200920:39Not ApplicableSP2
Mstscax.dll6.0.6002.221384,935,16818-May-200913:36IA-64SP2
Mstscax.mofNot Applicable1,96703-Apr-200920:40Not ApplicableSP2
Tsgqec.dll6.0.6002.2213880,38418-May-200913:39IA-64SP2
For all supported x64-based versions of Windows Server 2008 and Windows Vista
File nameFile versionFile sizeDateTimePlatformSP requirement
Aaclient.dll6.0.6001.22435151,55218-May-200914:02x64SP1
Aaclient.mofNot Applicable1,09701-Apr-200915:54Not ApplicableSP1
Mstscax.dll6.0.6001.224352,419,71218-May-200914:06x64SP1
Mstscax.mofNot Applicable1,96701-Apr-200915:55Not ApplicableSP1
Tsgqec.dll6.0.6001.2243545,05618-May-200914:07x64SP1

Hotfix information for Windows XP

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, the computer must run Windows XP Service Pack 3.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
For all supported x86-based versions of Windows XP SP3
File nameFile versionFile sizeDateTimePlatform
Lhmstscx.dll6.0.6001.224352,062,33620-May-200915:31x86

↑ Back to the top


Workaround

To work around this issue, use the up arrow key or down arrow key on the keyboard instead of the mouse to select the combo box items.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbautohotfix, kbexpertiseadvanced, kbfix, kbsurveynew, kbqfe, KB968358

↑ Back to the top

Article Info
Article ID : 968358
Revision : 2
Created on : 10/7/2011
Published on : 10/7/2011
Exists online : False
Views : 410