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FIX: The BizTalk Server FTP adapter does not retrieve files successfully from an IBM AIX-based FTP server that is set to the fr_FR locale


View products that this article applies to.

Symptoms

Consider the following scenario in Microsoft BizTalk Server: �
  • You have an IBM AIX-based FTP server on which the locale is set to fr_FR.
  • The BizTalk FTP adapter connects to the FTP server to retrieve some files.
In this scenario, the BizTalk FTP adapter does not successfully retrieve the files from the IBM AIX-based FTP server.

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Cause

When you use the FTP adapter to retrieve files from an IBM AIX-based FTP server, the FTP adapter first sends the SYST command to identify the server type. However, if the IBM AIX-based FTP server locale is set to fr_FR, the returned string is not interpreted correctly. Therefore, any later commands that are sent by the FTP adapter to retrieve files from the FTP server are not handled correctly.

Note An AIX-based FTP server that is set to the en_UK or en_US locale returns a response of "UNIX TYPE" to the SYST command. However, an AIX-based FTP server that is set to the fr_FR locale returns a response of "TYPE UNIX."

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Resolution

Hotfix information

Cumulative update information

BizTalk Server 2009 CU2

The hotfix that resolves this issue is included in cumulative update package 2 for BizTalk Server 2009.�

For more information about how to obtain the cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:�

2497794�Cumulative update package 2 for BizTalk Server 2009

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Microsoft BizTalk Server 2006 R2 installed.

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, you must restart the BizTalk Server Application service.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Interop.xceedftplib.dll3.6.1513.259,22406-Apr-200910:51x86
Microsoft.biztalk.coreadapter.dll3.6.1516.2104,30406-Apr-200910:51x86
Xceedftpbiztalk.dll3.6.1513.2300,88006-Apr-200910:52x86

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Workaround

To work around this problem, configure the IBM AIX-based FTP server to use the en-US locale settings.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbbtsadapters, kbsurveynew, kbautohotfix, kbexpertiseinter, kbhotfixserver, kbqfe, kbbiztalk2009presp1fix, KB967606

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Article Info
Article ID : 967606
Revision : 3
Created on : 3/18/2011
Published on : 3/18/2011
Exists online : False
Views : 457