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Windows Server 2008 Terminal Services licensing service leaks memory


View products that this article applies to.

Symptoms

The memory usage of the Windows Server 2008 Terminal Services licensing server may keep increasing. All memory is used up if the problem persists for a long time.

When new users try to connect to a Terminal Server that points to the leaking licensing server, they may receive an error message that states that there are no terminal services licenses available. Additionally, applications or services that are running on the computer may stop working because of exhausted memory resources.

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Cause

This problem occurs because the Terminal Services licensing service does not manage the allocated memory space correctly. It does not free up some allocated memory space. This causes the problem.

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Resolution

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Important Windows Vista and Windows Server 2008 hotfixes are included in the same packages. However, only one of these products may be listed on the �Hotfix Request� page. To request the hotfix package that applies to both Windows Vista and Windows Server 2008, just select the product that is listed on the page.

Prerequisites

You must have Windows Server 2008 and Terminal Services Licensing Service installed to apply this hotfix.

Restart Requirement

You have to restart the computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace a previously released hotfix.

File Information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2008 file information note
The .manifest files and the .mum files that are installed in each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. These files and their associated .cat (security catalog) files are critical to maintaining the state of the updated component. The .cat files are signed with a Microsoft digital signature. The attributes of these security files are not listed.

Windows Server 2008 x86
File nameFile versionFile sizeDateTimePlatform
Lserver.dll6.0.6001.22373468,99210-Feb-200905:33x86
Tlsmigplugin.dll6.0.6001.2237375,77610-Feb-200905:33x86
Tlsunattend.exe6.0.6001.223738,70410-Feb-200905:32x86
Tslicensing.events.xmlNot Applicable54918-Dec-200721:02Not Applicable
Windows Server 2008 x64
File nameFile versionFile sizeDateTimePlatform
Lserver.dll6.0.6001.22373642,04810-Feb-200905:55x64
Tlsmigplugin.dll6.0.6001.22373102,91210-Feb-200905:55x64
Tlsunattend.exe6.0.6001.2237310,24010-Feb-200905:54x64
Tslicensing.events.xmlNot Applicable54918-Dec-200721:02Not Applicable

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Workaround

To work around this issue, restart the Terminal Services licensing service.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

Additional file information for Windows Server 2008


Windows Server 2008 x86 other files
File nameFile versionFile sizeDateTimePlatform
Package_for_kb967592_server_0~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,41910-Feb-200918:26Not Applicable
Package_for_kb967592_server~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,43010-Feb-200918:26Not Applicable
X86_microsoft-windows-t..vices-licenseserver_31bf3856ad364e35_6.0.6001.22373_none_a188d2ceb7dbe67b.manifestNot Applicable97,88410-Feb-200906:03Not Applicable
Windows Server 2008 x64 other files
File nameFile versionFile sizeDateTimePlatform
Amd64_microsoft-windows-t..vices-licenseserver_31bf3856ad364e35_6.0.6001.22373_none_fda76e52703957b1.manifestNot Applicable97,94010-Feb-200906:24Not Applicable
Package_for_kb967592_server_0~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,42710-Feb-200918:26Not Applicable
Package_for_kb967592_server~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,43810-Feb-200918:26Not Applicable
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbexpertiseinter, kbsurveynew, kbbug, kbfix, kbqfe, KB967592

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Article Info
Article ID : 967592
Revision : 2
Created on : 10/7/2011
Published on : 10/7/2011
Exists online : False
Views : 259