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Storage Quota Warning messages that are sent to the user will bypass the restriction if a user configures an auto-forward rule or an auto-reply rule to send e-mail messages to a restricted distribution group


View products that this article applies to.

Symptoms

Consider the following scenario:
  • In a Microsoft Exchange Server 2003 environment, the user configures an auto-forward rule or an auto-reply rule to send e-mail messages to a restricted distribution group (DG).
  • The user does not have permission to send e-mail messages to that restricted DG.

In this scenario, any Storage Quota Warning messages sent to the user will bypass this restriction. Then the Storage Quota Warning messages will be delivered to the restricted DG.

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Cause

Storage Quota Warnings are currently not treated as Delivery Status Notification messages. Instead they are treated as System Messages. This behavior occurs because all the message attributes are copied from the original message to the forward or reply message.This includes the PR_CONTENT_IDENTIFIER. The PR_CONTENT_IDENTIFIER identifies the message as an ExSysMessage type (System Message) when the rule is proceeding with the message. In the Categorizer component, where restrictions are checked, System Messages automatically bypass any restriction check. Therefore the Storage Quota Warning message is delivered to the DG.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites


This hotfix requires Microsoft Exchange Server 2003 Service Pack 2 to be installed on the server because of file dependencies.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
836993 How to obtain the latest service packs for Exchange Server 2003

Restart requirement


You do not have to restart the computer after you apply this hotfix. However, the following services are restarted automatically when you apply this hotfix:
  • The Microsoft Exchange System Attendant service
  • The Microsoft Search service
  • The Internet Information Services (IIS) Admin Service and all dependent services

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The P1 version of this P2 has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTime
Cdo.dll6.5.7655.6726,01615-Jul-200916:36
Cdoex.dll6.5.7655.63,980,80015-Jul-200918:23
Davex.dll6.5.7655.61,135,61615-Jul-200918:16
Excdo.dll6.5.7655.63,666,43215-Jul-200918:23
Exoledb.dll6.5.7655.62,621,95215-Jul-200903:16
Exosal.dll6.5.7655.670,14415-Jul-200917:53
Lsmexhc.dll6.5.7655.6144,38415-Jul-200916:38
Madfb.dll6.5.7655.6526,84815-Jul-200918:23
Mdbmsg.dll6.5.7655.63,391,48815-Jul-200917:08
Rtdsmcal.dll6.5.7655.641,47215-Jul-200917:00
Store.exe6.5.7655.65,268,48015-Jul-200917:56

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: KB967223, kbqfe, kbexpertiseinter, kbautohotfix, kbhotfixserver, kbsurveynew

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Article Info
Article ID : 967223
Revision : 2
Created on : 9/17/2009
Published on : 9/17/2009
Exists online : False
Views : 220