Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FRx GL Index is Currently Locked by User


Symptoms

"FRx GL index is currently locked by user since 12:00:00 AM"This error occurs when attempting to connect to an FRx company. After deleting the GL index files (files ending in a .G32 extension) located in the FRx SysData directory, the error persists.

↑ Back to the top


Cause

When FRx is rebuilding a GL index file, it creates a .LCK file in the sysdata directory to track who is building the file and what time that process began. If FRx is terminated abnormally while this process occurs, due to an error message or ungraceful exit, the .LCK file will be left in the sysdata directory preventing further attempts to rebuild the index file.

↑ Back to the top


Resolution

If there are no other users building the .G32 file, delete the .LCK file and try connecting to the company again. For steps on how to locate the sysdata directory, refer to the knowledge base article How to Determine the Location of the SysData Directory. If this article does not resolve your issue, please contact your FRx support provider. Click here for a list of General Ledger vendors that provide support for FRx.

↑ Back to the top


References

↑ Back to the top


Keywords: kb

↑ Back to the top

Article Info
Article ID : 964735
Revision : 4
Created on : 9/2/2020
Published on : 9/2/2020
Exists online : False
Views : 62