Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

If you cancel the Select Certificate dialog box on a computer that is running Windows Vista or Windows Server 2008, you are prompted two times for user credentials to access a WebDAV site whose SSL setting for client certificates is set to "Acc...


View products that this article applies to.

Symptoms

Consider the following scenario:
  • On a Web Distributed Authoring and Versioning (WebDAV) site, you set the Secure Sockets Layer (SSL) setting for client certificates to Accept client certificates.
  • On a computer that is running Windows Vista or Windows Server 2008, you run the Add Network Location Wizard or the Map Network Drive Wizard to add this WebDAV site.
  • After you finish running the wizard, the Select Certificate dialog box appears. In the Select Certificate dialog box, you click Cancel.
In this scenario, you expect to obtain an instant connection to the WebDAV site or to receive a dialog box that requests the user's credentials. However, after you apply hotfix KB954809, you are prompted two times for user credentials. The second prompt may indicate that the input is invalid and has to be corrected at the next try.

Additionally, you may receive an error message that resembles the following:

The mapped network drive could not be created because the following error has occurred:
"The file cannot be accessed by the system."
Notes
  • When the SSL setting for client certificates is set to Accept client certificates, you expect that the user can provide a certificate or credentials to access the WebDAV site.
  • This problem does not occur on a computer that is running Windows XP or Windows Server 2003.

↑ Back to the top


Cause

Currently, the SSL setting for client certificates on a Web server can be configured for the following three options:
  • Ignore client certificates
  • Accept client certificates
  • Require client certificates
When this setting is configured to Accept client certificates, the server (WebDAV site) requires the client to send a certificate. If the client does not have a certificate, the server and the client can negotiate for other authentication mechanisms.

However, a WebDAV client that is running Windows Vista or Windows Server 2008 supports only the "Ignore" or "Require" options for the SSL setting for client certificates. Therefore, when you do not select a certificate, and you try to access the WebDAV site, this problem occurs.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Important Windows Vista and Windows Server 2008 hotfixes are included in the same packages. However, only one of these products may be listed on the �Hotfix Request� page. To request the hotfix package that applies to both Windows Vista and Windows Server 2008, just select the product that is listed on the page.

Prerequisites

To apply this hotfix on Windows Vista-based computer, you must have Windows Vista SP1 installed. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack
No prerequisites are required for Windows Server 2008-based computers.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Vista and Windows Server 2008 file information note

The MANIFEST files (.manifest) and MUM files (.mum) installed for each environment are listed separately. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files (attributes not listed) are signed with a Microsoft digital signature.
For all supported 32-bit versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Davclnt.dll6.0.6001.2236755,29603-Feb-200905:48x86
Mrxdav.sys6.0.6001.22367113,66403-Feb-200903:02x86
Webclnt.dll6.0.6001.22367198,65603-Feb-200905:48x86
For all supported 64-bit versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Davclnt.dll6.0.6001.2236773,72803-Feb-200906:11x64
Mrxdav.sys6.0.6001.22367137,72803-Feb-200903:33x64
Webclnt.dll6.0.6001.22367216,57603-Feb-200906:11x64
Mrxdav.sys6.0.6001.22367113,66403-Feb-200903:02x86

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

Additional file information for Windows Server 2008 and for Windows Vista

Additional files for all supported 32-bit versions of Windows Server 2008 and of Windows Vista
File namePackage_for_kb963047_client_1~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,641
Date (UTC)03-Feb-2009
Time (UTC)22:46
File namePackage_for_kb963047_client~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,430
Date (UTC)03-Feb-2009
Time (UTC)22:46
File namePackage_for_kb963047_server_0~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,408
Date (UTC)03-Feb-2009
Time (UTC)22:46
File namePackage_for_kb963047_server~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,430
Date (UTC)03-Feb-2009
Time (UTC)22:46
File nameX86_4d29678d9b73f3cb80e64a41ce5a45c9_31bf3856ad364e35_6.0.6001.22367_none_90d92ee142f6d319.manifest
File versionNot Applicable
File size1,059
Date (UTC)03-Feb-2009
Time (UTC)22:46
File nameX86_76a47018c1bb8bbb4e93aba30bc9efdd_31bf3856ad364e35_6.0.6001.22367_none_f6ad2241586ea0b5.manifest
File versionNot Applicable
File size709
Date (UTC)03-Feb-2009
Time (UTC)22:46
File nameX86_7e8e6266235d6500b723a1d9eb47d8e0_31bf3856ad364e35_6.0.6001.22367_none_a27c545f76adea30.manifest
File versionNot Applicable
File size1,412
Date (UTC)03-Feb-2009
Time (UTC)22:46
File nameX86_microsoft-windows-webdavredir-davclient_31bf3856ad364e35_6.0.6001.22367_none_941d2c546b872da3.manifest
File versionNot Applicable
File size5,069
Date (UTC)03-Feb-2009
Time (UTC)06:10
File nameX86_microsoft-windows-webdavredir-mrxdav_31bf3856ad364e35_6.0.6001.22367_none_14faa84cdf0397b9.manifest
File versionNot Applicable
File size13,642
Date (UTC)03-Feb-2009
Time (UTC)06:04
File nameX86_microsoft-windows-webdavredir-webclient_31bf3856ad364e35_6.0.6001.22367_none_55758cd1ccf996a0.manifest
File versionNot Applicable
File size6,904
Date (UTC)03-Feb-2009
Time (UTC)06:14
Additional files for all supported 64-bit versions of Windows Server 2008 and of Windows Vista
File nameAmd64_0fe3162b6ced683818c1885eede895c7_31bf3856ad364e35_6.0.6001.22367_none_4e9cd3c4955103bd.manifest
File versionNot Applicable
File size2,478
Date (UTC)03-Feb-2009
Time (UTC)22:46
File nameAmd64_cdc05809bb4ec1507ae7b810ebed3cb3_31bf3856ad364e35_6.0.6001.22367_none_1f1de26746abe79c.manifest
File versionNot Applicable
File size2,126
Date (UTC)03-Feb-2009
Time (UTC)22:46
File nameAmd64_microsoft-windows-webdavredir-davclient_31bf3856ad364e35_6.0.6001.22367_none_f03bc7d823e49ed9.manifest
File versionNot Applicable
File size5,087
Date (UTC)03-Feb-2009
Time (UTC)06:36
File nameAmd64_microsoft-windows-webdavredir-mrxdav_31bf3856ad364e35_6.0.6001.22367_none_711943d0976108ef.manifest
File versionNot Applicable
File size13,906
Date (UTC)03-Feb-2009
Time (UTC)06:28
File nameAmd64_microsoft-windows-webdavredir-webclient_31bf3856ad364e35_6.0.6001.22367_none_b1942855855707d6.manifest
File versionNot Applicable
File size6,934
Date (UTC)03-Feb-2009
Time (UTC)06:38
File namePackage_for_kb963047_client_1~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,375
Date (UTC)03-Feb-2009
Time (UTC)22:46
File namePackage_for_kb963047_client~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,438
Date (UTC)03-Feb-2009
Time (UTC)22:46
File namePackage_for_kb963047_server_0~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,416
Date (UTC)03-Feb-2009
Time (UTC)22:46
File namePackage_for_kb963047_server~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,438
Date (UTC)03-Feb-2009
Time (UTC)22:46
File nameWow64_microsoft-windows-webdavredir-mrxdav_31bf3856ad364e35_6.0.6001.22367_none_7b6dee22cbc1caea.manifest
File versionNot Applicable
File size8,609
Date (UTC)03-Feb-2009
Time (UTC)05:59

↑ Back to the top


Keywords: kbautohotfix, kbexpertiseinter, kbfix, kbbug, kbsurveynew, kbqfe, KB963047

↑ Back to the top

Article Info
Article ID : 963047
Revision : 2
Created on : 10/7/2011
Published on : 10/7/2011
Exists online : False
Views : 272