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Commerce Server 2007 product relationships may not be visible in Commerce Server Catalog Manager if the "Display Out of Stock Items" value is set to zero on the inventory resource


View products that this article applies to.

Symptoms

Consider the following scenario in Microsoft Commerce Server 2007:
  • You create a relationship between two products in a virtual catalog.
  • You set the Display Out of Stock Items value to 0 from the default value of -1 on the inventory resource in Commerce Server Manager.
In this scenario, you may no longer be able to see this product relationship in the Commerce Server Catalog Manager.

Note When you set the Display Out of Stock Items value back to -1, and then run the IISRESET command, you will be able to see the product relationship again.

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Cause

This problem occurs because of an issue in the stored procedure that returns the relationships for a category or product.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Commerce Server 2007 Service Pack 2 (SP2) installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File Information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Catalogcreate.sqlNot applicable1,150,53216-Jan-200914:24Not applicable

Installation instructions

After you extract the hotfix package, you will receive three following files:
  • CommerceServer2007SP2-KB962913-ENU.exe
  • Ctlg_GetCatalogRelationships.sql
  • Hotfix.txt
Install the CommerceServer2007SP2-KB962913-ENU.exe file to update the Catalogcreate.sql file. This will make sure that new catalog databases display product relationships correctly. Additionally, you must run the Ctlg_GetCatalogRelationships.sql file against the existing catalog databases to update the stored procedure.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

This hotfix will not let you establish relationships between two products in one virtual catalog that exist in different base catalogs that have their own independent inventory catalogs. For example, you have a TestVirtualCatalog virtual catalog that contains the following products:
  • Product1, which is referenced from Base Catalog 1
  • Product2, which is referenced from Base Catalog 2
Base Catalog 1 and Base Catalog 2 have their own inventory catalogs. If you want to establish a relationship between Product 1 and Product 2, Base Catalog 1 and Base Catalog 2 will have to share the same inventory catalog. For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: KB962913, kbqfe, kbfix, kbbug, kbsurveynew, kbexpertiseinter, kbautohotfix

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Article Info
Article ID : 962913
Revision : 3
Created on : 10/7/2011
Published on : 10/7/2011
Exists online : False
Views : 379