Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: The number of concurrently running orchestrations in BizTalk Server reaches 250, and you experience poor performance after you install the .NET Framework 2.0 SP1 or a later version of the .Net Framework


View products that this article applies to.

Symptoms

You install the Microsoft .NET Framework 2.0 SP1 or certain later versions of the .NET Framework on a computer that is running Microsoft BizTalk Server. When the server is under heavy load, you may notice that as many as 250 BizTalk orchestrations are running concurrently. Therefore, you experience poor performance on the server. Additionally, you may notice thatdownstream servers are overwhelmed by messages that are sent through BizTalk adapters during the heavy load condition.

Notes
  • You can monitor the number of concurrently running BizTalk orchestrations in Performance Monitor by using the "XLANG/s Orchestrations" - "Running orchestrations" counter. For more information, see the More Information section.
  • Because of certain file dependencies, the .NET Framework 3.5 and the .NET Framework 3.0 SP1 automatically install the .NET Framework 2.0 SP1.Also, the .NET Framework 3.5 SP1 automatically installs the .NET Framework 2.0 SP2. Therefore, this issue also occurs after you install the following versions of the .NET Framework:
    • .NET Framework 2.0 SP2
    • .NET Framework 3.0 SP1
    • .NET Framework 3.5
    • .NET Framework 3.5 SP1

↑ Back to the top


Cause

The number of running orchestrations is limited by the MaxWorkerThreads setting. The Microsoft .NET Framework 2.0 SP1 specifies a limit of 250. If you have not configured specifically the MaxWorkThreads setting for BizTalk Server, the number of concurrently running orchestrations can reach 250.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have BizTalk Server 2006 R2 installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, you must restart the BizTalk Server services after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Btsprccntnr.dll3.6.1533.278,15204-May-200916:10x86

↑ Back to the top


Workaround

To work around this issue, you can limit the number of orchestrations running at one time by creating the following CLR Hosting registry key together with the corresponding DWORD values:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\BTSSvc$BiztalkServerApplication\CLR Hosting]
"MaxIOThreads"=dword:00000032
"MaxWorkerThreads"=dword:00000032
"MinIOThreads"=dword:00000019
"MinWorkerThreads"=dword:00000019

Note These values are in hexadecimal and can be changed according to your actual requirements.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

If you are performance testing your application on BizTalk Server 2006 R2 and you encounter problems in your application that were not present when you ran the applicationon BizTalk Server 2004 or BizTalk Server 2006, you should consider applying this hotfix.

This hotfix sets the following default valuesif the CLR Hosting key is not specifically set:
MaxIOThreads=50
MaxWorkerThreads=50
MinIOThreads=25
MinWorkerThreads=25

Note These values are in decimal.

If you have a specific host for which you want the default values to be higher, you must manually create the registry entries as described in the Workaround section.

For more information about orchestration engine performance counters, visit the following Microsoft Web site:
http://technet.microsoft.com/en-us/library/dd801079.aspx

For more information about configuration settings that can affect the performance of BizTalk Server adapters, visit the following Microsoft Web site:
http://msdn.microsoft.com/en-us/library/dd800300.aspx

For more information about the ThreadPool class in the .NET Framework 2.0, visit the following Microsoft Web site:
http://msdn.microsoft.com/en-us/library/system.threading.threadpool(VS.80).aspx

For more information about the ThreadPool class in the .NET Framework 3.5, visit the following Microsoft Web site:
http://msdn.microsoft.com/en-us/library/system.threading.threadpool.aspx

↑ Back to the top


Keywords: kbsurveynew, kbautohotfix, kbbtsadapters, kbexpertiseinter, kbhotfixserver, kbqfe, kbbiztalk2006r2sp1fix, KB961810

↑ Back to the top

Article Info
Article ID : 961810
Revision : 3
Created on : 6/11/2009
Published on : 6/11/2009
Exists online : False
Views : 468