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Error message when you try to run a Microsoft Dynamics eConnect Destination Adapter integration in Integration Manager for Microsoft Dynamics GP: "Login failed for user"


Symptoms

When you try to run a Microsoft Dynamics eConnect Adapter destination in Integration Manager for Microsoft Dynamics GP, you receive one of the following error messages:
DOC 1 ERROR: Version=10.0.0.0

Unique MessageId =

Error Number = -2147467259

Error Description = Login failed for user ''. The user is not associated with a trusted SQL Server connection.

Error Source = Microsoft OLE DB Provider for SQL Server

The destination could not be initialized due to the following problem:

The server process could not be started because the configured identity is incorrect. Check the username and password. (Exception from HRESULT: 0x8000401A)

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Cause

This problem will occur if you do not have a domain user name and a domain password set up in the COM+ application in eConnect for Microsoft Dynamics GP.

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Resolution

For Windows XP

To resolve this problem, follow these steps:
  1. Start Component Services. To do this, click Start, click Settings, click Control Panel, and then click Component Services.
  2. Expand Component Services, expand Computers, expand My Computer, and then expand Com+ Applications.
  3. Right-click eConnect 10 for Microsoft Dynamics GP, and then click Properties.
  4. Click the Identity tab, and then click to select This User.
  5. Enter the domain administrator user ID and the domain password.
  6. Click Apply.
  7. Click OK to close the window.
  8. Stop the eConnect 10 for Microsoft Dynamics GP COM+ component.
  9. Start the eConnect 10 for Microsoft Dynamics GP COM+ component.
  10. Run the integration.

For Windows Vista

To resolve this problem, follow these steps:
  1. Start Component Services.
  2. Click Start, and then click Run.
  3. Type dcomcnfg, and then click OK.
  4. Expand Component Services, expand Computers, expand My Computer, and then expand Com+ Applications.
  5. Right-click eConnect 10 for Microsoft Dynamics GP, and then click Properties.
  6. Click the Identity tab, and then click to select This User.
  7. Enter the domain administrator user ID and the domain password.
  8. Click Apply.
  9. Click OK to close the window.
  10. Stop the eConnect 10 for Microsoft Dynamics GP COM+ component.
  11. Start the eConnect 10 for Microsoft Dynamics GP COM+ component.
  12. Run the integration.

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Keywords: kbexpertiseadvanced, kberrmsg, kbsurveynew, kbmbspartner, kbexpertisebeginner, kbtshoot, kbmbsmigrate, kbprb, kbexpertiseinter, kb

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Article Info
Article ID : 961566
Revision : 1
Created on : 1/7/2017
Published on : 7/13/2012
Exists online : False
Views : 87