Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

A Windows Server 2003 Service Pack 2-based computer or a Windows XP Service Pack 3-based computer randomly crashes


View products that this article applies to.

Symptoms

A computer that is running Windows Server 2003 Service Pack 2 (SP2), Windows XP Service Pack 2 (SP2) or Windows XP Service Pack 3 (SP3) randomly crashes.

↑ Back to the top


Cause

This problem occurs because of a time issue in memory management. When the issue occurs, the dirty bit is set for a memory page. However, the corresponding write bit is not set. This behavior causes an infinite loop and makes the computer stop responding.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running Windows Server 2003 Service Pack 2 (SP2).

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
For all supported x86-based versions of Windows Server 2003 SP2
File nameFile versionFile sizeDateTimePlatformSP requirement
Ntkrnlmp.exe5.2.3790.45522,499,58415-Jul-200914:58Not ApplicableSP2
Ntkrnlpa.exe5.2.3790.45522,310,65615-Jul-200913:43x86SP2
Ntkrpamp.exe5.2.3790.45522,351,10415-Jul-200913:43Not ApplicableSP2
Ntoskrnl.exe5.2.3790.45522,458,11215-Jul-200914:58x86SP2
For all supported x64-based versions of Windows Server 2003 SP2 and Windows XP Service Pack 2 (SP2)
File nameFile versionFile sizeDateTimePlatformSP requirement
Hal.dll5.2.3790.4354280,06416-Jul-200909:13x64SP2
Ntkrnlmp.exe5.2.3790.45524,613,12016-Jul-200909:13x64SP2
Ntoskrnl.exe5.2.3790.45524,540,41616-Jul-200909:13x64SP2
For all supported Itanium-based versions of Windows Server 2003 SP2
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntdll.dll5.2.3790.44551,646,59216-Jul-200909:16IA-64SP2Not Applicable
Ntkrnlmp.exe5.2.3790.45526,581,24816-Jul-200909:16IA-64SP2Not Applicable
Wntdll.dll5.2.3790.4455775,16816-Jul-200909:16x86SP2WOW

Hotfix Information


A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

This hotfix requires Windows XP service pack 2 to be installed on the computer.
322389 How to obtain the latest Windows XP service pack

Restart Requirement

You have to restart the computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
For all supported x86-based versions of Windows XP Service Pack 3 (SP3)
File nameFile versionFile sizeDateTimePlatformSP requirement
Ntkrnlmp.exe5.1.2600.58452,145,28014-Jul-200911:13x86SP3
Ntkrnlpa.exe5.1.2600.58452,066,17614-Jul-200910:20x86SP3
Ntkrpamp.exe5.1.2600.58452,023,93614-Jul-200910:20x86SP3
Ntoskrnl.exe5.1.2600.58452,189,18414-Jul-200911:15x86SP3
For all supported x86-based versions of Windows XP Service Pack 2 (SP2)
File nameFile versionFile sizeDateTimePlatformSP requirement
Ntkrnlmp.exe5.1.2600.36282,142,72006-Oct-200911:21x86SP2
Ntkrnlpa.exe5.1.2600.36282,062,97606-Oct-200910:44x86SP2
Ntkrpamp.exe5.1.2600.36282,020,86406-Oct-200910:44x86SP2
Ntoskrnl.exe5.1.2600.36282,185,98406-Oct-200911:23x86SP2

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbautohotfix, kbexpertiseadvanced, kbfix, kbsurveynew, kbqfe, KB961555

↑ Back to the top

Article Info
Article ID : 961555
Revision : 3
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 248