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FIX: The BizTalk Adapter for TIBCO EMS does not reconnect to the TIBCO EMS server after the TIBCO EMS server becomes available to reconnect


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You use the Microsoft BizTalk Adapter for TIBCO Enterprise Message Service (EMS) as a receive adapter.
  • You use the BizTalk Adapter for TIBCO EMS to poll data from a TIBCO EMS server.
  • The BizTalk Adapter for TIBCO EMS loses the connection to the TIBCO EMS server for some reason. For example, the TIBCO EMS server is restarted.
  • The BizTalk Adapter for TIBCO EMS tries to reconnect to the TIBCO EMS server.
In this scenario, you receive an error message that resembles the following:
An exception occurred when attempting to connect to the TIBCO EMS server.
Error: Failed to connect to the server at <path>
Additionally, after the TIBCO EMS server becomes available to reconnect, the BizTalk Adapter for TIBCO EMS does not reconnect to the TIBCO EMS server. For example, after the TIBCO EMS server is restarted successfully, the BizTalk Adapter for TIBCO EMS does not reconnect to the TIBCO EMS server. Meanwhile, the status of the receive location is displayed as Enabled.

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Cause

This problem occurs because of a problem in the BizTalk Adapter for TIBCO EMS. This problem prevents the Retry Count property and the Retry Interval property for the receive adapter from taking effect. Instead, the BizTalk Adapter for TIBCO EMS tries to reconnect five times. If the connection is not resumed after the five attempts, the status of the receive location is still displayed as Enabled.

Note You can configure the Retry Count property and the Retry Interval property in the TIBCO EMS Transport Properties window. For more information, see the "More Information" section.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have the Microsoft BizTalk Adapters for Enterprise Applications installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

Post-installation steps

After you apply this hotfix by running the Setup.exe file, you must run the GACUtil.bat file to register the updated Microsoft.BizTalk.Adapters.CoreReceiver.dll file and the updated Microsoft.biztalk.adapters.tibcoems.dll file in the global assembly cache. For more information, see the GACUtil_Readme.txt file that is included in the hotfix package.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Microsoft.biztalk.adapters.corereceiver.dll1.0.1171.032,13612-Mar-200921:38x86
Microsoft.biztalk.adapters.tibcoems.dll1.0.1171.076,16812-Mar-200921:38x86

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Workaround

To work around this problem, restart the BizTalk hosted instance in the BizTalk Server Administration console to resume the connection.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

After you apply this hotfix, the specified values for the Retry Count property and for the Retry Interval property take effect. When the BizTalk Adapter for TIBCO EMS loses the connection to the TIBCO EMS server, the BizTalk Adapter for TIBCO EMS tries to reconnect according to the specified values.

Note The BizTalk Adapter for TIBCO EMS tries to reconnect five times if the specified value of the Retry Count property is less than five.

If the BizTalk Adapter for TIBCO EMS still cannot reconnect after the specified number of attempts, the receive location with the receive adapter is disabled.

For more information about the BizTalk Adapter for TIBCO EMS, visit the following Microsoft Developer Network (MSDN) Web sites:For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

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Keywords: kbbtsadapters, kbsurveynew, kbautohotfix, kbexpertiseinter, kbhotfixserver, kbqfe, KB961541

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Article Info
Article ID : 961541
Revision : 1
Created on : 4/16/2009
Published on : 4/16/2009
Exists online : False
Views : 451