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The subject name of a computer certificate that is issued by a Windows Server 2003-based server is set to the user principal name (UPN) of the computer account after you apply hotfix 943089


View products that this article applies to.

Symptoms

You apply hotfix 943089 on a Windows Server 2003-based server that hosts Certificate Services. After you do this, the subject name of a computer certificate that is issued by this server is set to the user principal name (UPN) of the computer account for which the certificate is issued.

Before you apply hotfix 943089, the subject name of the computer certificate that is issued by a Microsoft certification authority (CA) server is built from the DNS name of the computer account.

Because of this change, applications that expect the subject name of the certificate to contain the DNS name of the computer account may become unable to use a certificate that is created in the new format.

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Cause

This change is introduced by hotfix 943089. This hotfix was released to resolve an issue in which the Subject Alt Name (SAN) field of the issued certificate contains the DNS name instead of the UPN of the computer account for which the certificate is issued.

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Resolution

To restore the pre-hotfix 943089 method of building the subject name from the DNS name of the computer account, apply hotfix 961515 on the Windows Server 2003-based server that hosts Certificate Services.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 or Windows Server 2003 Service Pack 2 installed on the server.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

Registry information

To use this hotfix, you do not have to change the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 Service Pack 1, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Certpdef.dll5.2.3790.3280118,78413-Jan-200914:54x86
Windows Server 2003 Service Pack 2, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Certpdef.dll5.2.3790.4445118,78413-Jan-200916:08x86
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Certpdef.dll5.2.3790.3280178,68813-Jan-200916:07x64SP1Not Applicable
Wcertpdef.dll5.2.3790.3280118,78413-Jan-200916:07x86SP1WOW
Windows Server 2003 Service Pack 2, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Certpdef.dll5.2.3790.4445178,68813-Jan-200916:11x64SP2Not Applicable
Wcertpdef.dll5.2.3790.4445118,78413-Jan-200916:11x86SP2WOW
Windows Server 2003 Service Pack 1, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Certpdef.dll5.2.3790.3280300,03213-Jan-200916:07IA-64SP1Not Applicable
Wcertpdef.dll5.2.3790.3280118,78413-Jan-200916:07x86SP1WOW
Windows Server 2003 Service Pack 2, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Certpdef.dll5.2.3790.4445300,03213-Jan-200916:07IA-64SP2Not Applicable
Wcertpdef.dll5.2.3790.4445118,78413-Jan-200916:08x86SP2WOW

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
943089 A Windows Server 2003-based enterprise CA issues certificates that have incorrect alternate subject names and the certificates are not Network Access Protection (NAP)-compliant
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbqfe, kbautohotfix, kbexpertiseadvanced, kbfix, kbsurveynew, KB961515

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Article Info
Article ID : 961515
Revision : 2
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 1318