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The IPsec client can connect to a Windows Server 2003-based server even when the StrongCRLCheck attribute is set to 1 and a revoked certificate exists in the certificate chain


View products that this article applies to.

Symptoms

Consider the following scenario:
  • In a network environment, you have an enterprise root certification authority (CA). Also, an intermediate CA has a certificate that was signed by the root CA.
  • On a Windows Server 2003-based server, the value of the StrongCRLCheck IPsec attribute is set to 1.
  • A computer certificate is signed by the intermediate CA to an IPsec client.
  • There is no certificate revocation list (CRL) distribution point in the computer certificate.
  • The certificate of the intermediate CA is revoked.
In this scenario, the IPsec client can still connect to the Windows Server 2003-based server. However, when the StrongCRLCheck attribute is set to 1, and the certificate of the intermediate CA is revoked, the connection should be denied.

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Cause

When IPsec clients try to connect to the server, the Oakley module on the server begins a client validation. During the validation, the client provides the Oakley module with a certificate chain in the following order:
  1. Client certificate
  2. Intermediate CA certificate
  3. Root CA certificate
If the value of StrongCRLCheck is 1, you expect that the Oakley module checks whether any certificate is revoked. If any certificate in this chain is revoked, the server should disallow the connection.

This issue occurs because, in the scenario in the "Symptoms" section, the Oakley module only checks whether the first certificate in the chain is revoked. If the first certificate is not revoked, the Oakley module allows the connection.

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Resolution

Hotfix information for Windows Server 2003

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, Windows Server 2003 Service Pack 1 (SP1) or Windows Server 2003 SP2 must be installed on the computer.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

Registry information

To use this hotfix, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 SP1, x86-based version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Oakley.dll5.2.3790.3287277,50423-Jan-200919:51x86SP1
W03a2409.dll5.2.3790.328740,96023-Jan-200910:05x86SP1
Windows Server 2003 SP2, x86-based version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Oakley.dll5.2.3790.4451352,25623-Jan-200920:00x86
Windows Server 2003 SP1, Itanium-based version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Oakley.dll5.2.3790.3287547,32823-Jan-200904:06IA-64SP1Not applicable
W03a2409.dll5.2.3790.328739,93623-Jan-200904:06IA-64SP1Not applicable
Woakley.dll5.2.3790.3287277,50423-Jan-200904:06x86SP1WOW
Ww03a2409.dll5.2.3790.328740,96023-Jan-200904:06x86SP1WOW
Windows Server 2003 SP2, Itanium-based version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Oakley.dll5.2.3790.4451549,88823-Jan-200904:10IA-64SP2Not applicable
Woakley.dll5.2.3790.4451352,25623-Jan-200904:10x86SP2WOW
Windows Server 2003, x64-based version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Oakley.dll5.2.3790.3287392,70423-Jan-200904:06x64SP1Not applicable
W03a2409.dll5.2.3790.328741,47223-Jan-200904:06x64SP1Not applicable
Woakley.dll5.2.3790.3287277,50423-Jan-200904:06x86SP1WOW
Ww03a2409.dll5.2.3790.328740,96023-Jan-200904:06x86SP1WOW
Windows Server 2003 SP2, x64-based version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Oakley.dll5.2.3790.4451394,24023-Jan-200904:12x64SP2Not applicable
Woakley.dll5.2.3790.4451352,25623-Jan-200904:12x86SP2WOW
Windows XP, x64-based version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Oakley.dll5.2.3790.3287392,70423-Jan-200904:06x64SP1Not applicable
W03a2409.dll5.2.3790.328741,47223-Jan-200904:06x64SP1Not applicable
Woakley.dll5.2.3790.3287277,50423-Jan-200904:06x86SP1WOW
Ww03a2409.dll5.2.3790.328740,96023-Jan-200904:06x86SP1WOW
Windows XP SP2, x64-based version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Oakley.dll5.2.3790.4451394,24023-Jan-200904:12x64SP2Not applicable
Woakley.dll5.2.3790.4451352,25623-Jan-200904:12x86SP2WOW

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

You can use the StrongCRLCheck registry entry to change the StrongCRLCheck setting. This entry is available in the following location:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\PolicyAgent\Oakley
Or, you can run the Netsh ipsec dynamic set config property=strongcrlcheck value=value command to change the StrongCRLCheck setting.

Note Valid values for the StrongCRLCheck setting are 0, 1, and 2.

You can run the netsh ipsec dynamic show config command to check the IPsec configuration parameters. The output of this command resembles the following.
IPSecDiagnostics       : 0
IKElogging             : 0
StrongCRLCheck         : 1
IPSecloginterval       : 3600
IPSecexempt            : 1
Boot Mode              : Permit
Boot Mode Exemptions   :
Protocol  Src Port  Dst Port  Direction
--------- --------- --------- ---------
UDP           0        68     Inbound
For more information about the StrongCRLCheck setting, see the "CRL Checking" section on the following Microsoft Web site: For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbexpertiseadvanced, kbfix, kbsurveynew, kbqfe, KB961361

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Article Info
Article ID : 961361
Revision : 2
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 316