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FIX: The BizTalk Adapter for TIBCO EMS does not delete messages from the JMS queue after the adapter successfully receives the messages in BizTalk Server 2006 R2


View products that this article applies to.

Symptoms

Consider the following scenario in Microsoft BizTalk Server 2006 R2:
  • You use the Microsoft BizTalk Adapter for TIBCO Enterprise Message Service (EMS) as a receive adapter.
  • You use the BizTalk Adapter for TIBCO EMS to poll data from the Java Message Service (JMS) queue on a TIBCO EMS server.
  • You set the Use Transaction parameter to "Yes" on the property page of BizTalk adapter for TIBCO EMS.
In this scenario, after the BizTalk Adapter for TIBCO EMS successfully receives the messages, the messages are not deleted from the JMS queue on the TIBCO EMS server.

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Cause

This problem occurs because of a problem in the BizTalk Adapter for TIBCO EMS.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have the Microsoft BizTalk Adapters for Enterprise Applications installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, you must restart the BizTalk host instance after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

Post-installation steps

After you apply this hotfix, a new registry value called DeleteAfterPoll is available. The DeleteAfterPoll registry value specifies whether the messages are deleted from the JMS queue after they are successfully received by the BizTalk Adapter for TIBCO EMS.

If you set the Use Transaction parameter to Yes on the property page of BizTalk Adapter for TIBCO EMS and want to make sure that the messages are deleted from the JMS queue after they are received by the BizTalk Adapter for TIBCO EMS, you must make the following registry changes:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\BizTalkAdapters\Config\Global\Adapters\TibcoEMS
  3. On the Edit menu, point to New, and then click String Value.
  4. Type DeleteAfterPoll, and then press Enter.
  5. On the Edit menu, click Modify.
  6. Type True to set the value.

    Notes
    • This value is case-sensitive.
    • If the DeleteAfterPoll registry value does not exist or if it is set to any value other than True, messages are not deleted from the JMS queue after the messages are received by the BizTalk Adapter for TIBCO EMS.
  7. Restart the BizTalk host instance.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Microsoft.biztalk.adapters.tibcoems.dll1.0.5018.075,64029-Dec-200815:31x86
Note Because of file dependencies, the most recent hotfix that contains these files may also contain additional files.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

If you set Use Transaction�parameter to No on the property page of the BizTalk Adapter for TIBCO EMS adapter, messages are deleted automatically from the JMS queue after they are received by the BizTalk Adapter for TIBCO EMS.

For more information about the BizTalk Adapter for TIBCO EMS, visit the following MSDN websites:�For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbbtsadapters, kbbiztalk2006r2sp1fix, kbbug, kbexpertiseinter, kbfix, kbhotfixserver, kbqfe, kbautohotfix, KB961346

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Article Info
Article ID : 961346
Revision : 2
Created on : 2/16/2011
Published on : 2/16/2011
Exists online : False
Views : 493