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When you start the Terminal Services Manager tool in Windows Server 2003, the tool crashes, and event ID 1000 is logged on a computer that has multiple processors


View products that this article applies to.

Symptoms

On a computer that is running Windows Server 2003, when you start the Terminal Services Manager tool (Tsadmin.exe), the Terminal Services Manager tool may randomly crash. This problem occurs when the computer has multiple processors.

When this problem occurs, an event ID 1000 that resembles the following event is logged in the Application log:

Event Type: Error
Event Source: Application Error
Event Category: (100)
Event ID: 1000
Date: <Date>
Time: <Time>
User: N/A
Computer: <ComputerName>
Description:
Faulting application tsadmin.exe, version 5.2.3790.3959, faulting module tsadmin.exe, version 5.2.3790.3959, fault address 0x0000c670.

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Cause

This problem occurs because of a timing issue in the Terminal Services Manager tool.

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Resolution

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2003 Service Pack 1 or Windows Server 2003 Service Pack 2 on the computer.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 1, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Tsadmin.exe5.2.3790.3278283,13609-Jan-200915:28x86
Windows Server 2003 with Service Pack 1, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Tsadmin.exe5.2.3790.3278433,15209-Jan-200904:25x64
Windows Server 2003 with Service Pack 1, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Tsadmin.exe5.2.3790.3278752,64009-Jan-200904:25IA-64
Windows Server 2003 with Service Pack 2, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Tsadmin.exe5.2.3790.4443283,13609-Jan-200915:27x86
Windows Server 2003 with Service Pack 2, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Tsadmin.exe5.2.3790.4443433,15209-Jan-200904:31x64
Windows Server 2003 with Service Pack 2, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Tsadmin.exe5.2.3790.4443752,64009-Jan-200904:28IA-64

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Workaround

To work around this problem, delete following registry entry before you start the Terminal Services Manager tool:
HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Terminal Server\TSADMIN\Placement
Note This workaround only temporarily resolves this problem. After you restart the computer, this problem will occur again.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base: -
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbexpertiseadvanced, kbfix, kbautohotfix, kbsurveynew, kbqfe, kbhotfixserver, KB961151

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Article Info
Article ID : 961151
Revision : 1
Created on : 1/20/2009
Published on : 1/20/2009
Exists online : False
Views : 243