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Error message when a Windows Server 2003-based computer is shutting down: "Stop error code 0x000000CE (DRIVER_UNLOADED_WITHOUT_CANCELLING_PENDING_OPERATIONS)" or "Stop error code 0x00000050 (PAGE_FAULT_IN_NONPAGED_AREA)"


View products that this article applies to.

Symptoms

When you restart or shut down a Windows Server 2003-based computer, you receive one of the following Stop error messages during the shutdown process:
Stop 0x000000CE (parameter1, 0x00000000, parameter3, 0x00000000)
DRIVER_UNLOADED_WITHOUT_CANCELLING_PENDING_OPERATIONS
Stop 0x00000050 (parameter1, 0x00000000, parameter3, 0x00000000)
PAGE_FAULT_IN_NONPAGED_AREA
Notes
  • The parameters in these Stop error messages may vary, depending on the computer's configuration.
  • This problem occurs randomly.

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Cause

When the system is shutting down, a work item that is related to the Mrxsmb.sys driver is inserted into a queue by the ExQueueWorkItem function. However, the ExQueueWorkItem function does not provide a mechanism to verify that the device object that is associated with the specified work item is available before the work item is processed. Therefore, if the Mrxsmb.sys driver is unloaded before the queued work item finishes, the system triggers a stop error.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 or Windows Server 2003 Service Pack 2 installed.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

889100 How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 1, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Mrxsmb.sys5.2.3790.3276438,78407-Jan-200911:39x86
Windows Server 2003 with Service Pack 2, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Mrxsmb.sys5.2.3790.4441438,78407-Jan-200911:44x86
Windows Server 2003 with Service Pack 1, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Mrxsmb.sys5.2.3790.32761,172,99207-Jan-200900:41IA-64
Windows Server 2003 with Service Pack 2, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Mrxsmb.sys5.2.3790.44411,173,50407-Jan-200900:47IA-64
Windows Server 2003 with Service Pack 1, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Mrxsmb.sys5.2.3790.3276786,94407-Jan-200900:41x64
Windows Server 2003 with Service Pack 2, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Mrxsmb.sys5.2.3790.4441787,45607-Jan-200900:49x64
Windows XP Professional x64 Edition with Service Pack 1
File nameFile versionFile sizeDateTimePlatform
Mrxsmb.sys5.2.3790.3276786,94407-Jan-200900:41x64
Windows XP Professional x64 Edition with Service Pack 2
File nameFile versionFile sizeDateTimePlatform
Mrxsmb.sys5.2.3790.4441787,45607-Jan-200900:49x64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

The ExInitializeWorkItem and ExQueueWorkItem functions can be used only when the specified work item is not associated with any device object or device stack. In all other cases, drivers should use the IoAllocateWorkItem, IoFreeWorkItem, and IoQueueWorkItem routines. Only these routines guarantee that the device object that is associated with the specified work item remains available until the work item has been processed.

For more information, visit the following Microsoft Developer Network Web site:For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Technical support for x64-based versions of Microsoft Windows

If your hardware came with a Microsoft Windows x64 edition already installed, your hardware manufacturer provides technical support and assistance for the Windows x64 edition. In this case, your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation by using unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you must have technical help with a Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware. If you purchased a Windows x64 edition such as a Windows Server 2003 x64 edition separately, contact Microsoft for technical support.

For product information about Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about x64-based versions of Windows Server 2003, visit the following Microsoft Web site:

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Keywords: kb, kbautohotfix, kbexpertiseinter, kbsurveynew, kbbug, kbfix, kbhotfixserver, kbqfe

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Article Info
Article ID : 960882
Revision : 1
Created on : 1/7/2017
Published on : 1/18/2012
Exists online : False
Views : 218