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Error message when you call the CreateProcess function to start a process of a console application by using an account other than the current logon account in Windows Server 2003: "The application failed to initialize properly (0xc0000142)"


View products that this article applies to.

Symptoms

Consider the following scenario. You have applications that meet the following requirements in Windows Server 2003:
  • The applications are console applications.
  • The applications do not display an interactive window.
  • The applications run under an account other than the current Windows logon account.
  • You call the CreateProcess function to create processes of these applications by specifying the NULL value for the Desktop parameter in the STARTUPINFO structure argument.
When you start processes of these applications, you may receive the following error message:
The application failed to initialize properly (0xc0000142).
This problem occurs if other processes of these applications are ending when this process starts.

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Cause

When a process is ending, the process releases the Desktop handle. However, there is a small timing issue that may prevent other starting processes from opening the Desktop handle. Therefore, some starting processes may not be initialized, and you receive the error message that is mentioned in the "Symptoms" section.

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Resolution

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2003 Service Pack 2 on the computer.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 2, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Winsrv.dll5.2.3790.4574301,56819-Aug-200905:39x86
Windows Server 2003 with Service Pack 2, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Winsrv.dll5.2.3790.4574513,53619-Aug-200903:35x64
Windows Server 2003 with Service Pack 2, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Winsrv.dll5.2.3790.4574820,22419-Aug-200903:32IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base: -
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbexpertiseadvanced, kbfix, kbautohotfix, kbsurveynew, kbqfe, KB960266

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Article Info
Article ID : 960266
Revision : 3
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 240