Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Stop error on a Windows Server 2003 SP2-based terminal server or a Windows Server 2008 SP2-based terminal server when users print documents in terminal sessions: "0x0000008E" or "0x00000050"


View products that this article applies to.

Symptoms

A Windows Server 2003 SP2-based terminal server or a Windows Sever 2008 SP2-based terminal server may restart automatically when users print documents in terminal sessions. When this problem occurs, one of the following stop error codes occurs on the terminal server:
  • 0x0000008E
  • 0x00000050

↑ Back to the top


Cause

This problem occurs when the Win32k.sys module incorrectly dereferences a null pointer because of the incorrect cleanup of Graphics Device Interface (GDI) surface objects.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, the computer must have Windows Server 2003 Service Pack 2 installed or Windows Server 2008 Service Pack 2 installed.

For more information about how to obtain a Windows Server 2003 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003
For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
968849� How to obtain the latest service pack for Windows Server 2008

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

Registry information

To use this hotfix, you do not have to make any changes to the registry.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2003 file information notes
  • In addition to the files that are listed in these tables, this hotfix also installs an associated security catalog file (KB959828.cat) that is signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2003 SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Win32k.sys5.2.3790.44741,850,88012-Mar-200912:46x86
For all supported x64-based versions of Windows Server 2003 SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Win32k.sys5.2.3790.44744,545,53612-Mar-200915:20x64
For all supported IA-64-based versions of Windows Server 2003 SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Win32k.sys5.2.3790.44745,570,56012-Mar-200915:17IA-64
Windows Server 2008 file information notes
Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    Collapse this tableExpand this table
    VersionProductSR_LevelService branch
    6.0.600 2 . 22xxxWindows Server 2008SP2LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Win32k.sys6.0.6002.226722,051,58406-Jul-201115:09x86
For all supported x64-based versions of Windows Server 2008
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Win32k.sys6.0.6002.226722,766,84806-Jul-201115:34x64
For all supported IA-64-based versions of Windows Server 2008
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Win32k.sys6.0.6002.226726,659,07206-Jul-201115:51IA-64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 � Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008

Additional files for all supported x86-based versions of Windows Server 2008
Collapse this tableExpand this table
File nameUpdate.mum
File versionNot Applicable
File size3,068
Date (UTC)07-Jul-2011
Time (UTC)06:37
PlatformNot Applicable
File nameX86_92675b70b693017685f34e092b836a30_31bf3856ad364e35_6.0.6002.22672_none_865a7cc8b9b47621.manifest
File versionNot Applicable
File size694
Date (UTC)07-Jul-2011
Time (UTC)06:37
PlatformNot Applicable
File nameX86_microsoft-windows-win32k_31bf3856ad364e35_6.0.6002.22672_none_bb19e8bdb1019e2b.manifest
File versionNot Applicable
File size6,543
Date (UTC)06-Jul-2011
Time (UTC)19:12
PlatformNot Applicable
Additional files for all supported x64-based versions of Windows Server 2008
Collapse this tableExpand this table
File nameAmd64_c6993762a0142baae8d92177dd35e507_31bf3856ad364e35_6.0.6002.22672_none_d55007223c640033.manifest
File versionNot Applicable
File size1,038
Date (UTC)07-Jul-2011
Time (UTC)06:38
PlatformNot Applicable
File nameAmd64_microsoft-windows-win32k_31bf3856ad364e35_6.0.6002.22672_none_17388441695f0f61.manifest
File versionNot Applicable
File size6,559
Date (UTC)07-Jul-2011
Time (UTC)05:03
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size3,092
Date (UTC)07-Jul-2011
Time (UTC)06:38
PlatformNot Applicable
File nameWow64_microsoft-windows-win32k_31bf3856ad364e35_6.0.6002.22672_none_218d2e939dbfd15c.manifest
File versionNot Applicable
File size5,013
Date (UTC)06-Jul-2011
Time (UTC)19:00
PlatformNot Applicable
Additional files for all supported IA-64-based versions of Windows Server 2008
Collapse this tableExpand this table
File nameIa64_7f9898d15366ac9f689c2c2a351d18b3_31bf3856ad364e35_6.0.6002.22672_none_f57507d9c0e61ac8.manifest
File versionNot Applicable
File size1,036
Date (UTC)07-Jul-2011
Time (UTC)06:37
PlatformNot Applicable
File nameIa64_microsoft-windows-win32k_31bf3856ad364e35_6.0.6002.22672_none_bb1b8cb3b0ffa727.manifest
File versionNot Applicable
File size6,551
Date (UTC)07-Jul-2011
Time (UTC)05:00
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size2,247
Date (UTC)07-Jul-2011
Time (UTC)06:37
PlatformNot Applicable
File nameWow64_microsoft-windows-win32k_31bf3856ad364e35_6.0.6002.22672_none_218d2e939dbfd15c.manifest
File versionNot Applicable
File size5,013
Date (UTC)06-Jul-2011
Time (UTC)19:00
PlatformNot Applicable

↑ Back to the top


Keywords: kbautohotfix, kbexpertiseadvanced, kbfix, kbsurveynew, kbqfe, kbhotfixserver, KB959828

↑ Back to the top

Article Info
Article ID : 959828
Revision : 7
Created on : 8/11/2011
Published on : 8/11/2011
Exists online : False
Views : 525