Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

An Exchange View-Only Administrator can review user mailbox contents by using an administrative application


View products that this article applies to.

Symptoms

In an Exchange 2003 environment, a standard windows user account that has been delegated "Exchange View-Only Administrator" permissions by using the Exchange Administration Delegation Wizard at the organization level. You expect that the Exchange View-Only Administrator can view the Exchange configuration only. However, the standard windows user account can read the contents of any message in a mailbox store in the organization unexpectedly. For example, this Exchange View-Only Administrator can access the contents of the other users' mailboxes by using the PFDavAdmin tool.

↑ Back to the top


Cause

This issue occurs when the Exchange View-Only Administrator uses an administrative application to access the Exchange data. In this scenario, the View-Only Administrator has read access to all objects in the Exchange store. No additional checks are performed.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

This hotfix requires Microsoft Exchange Server 2003 Service Pack 2 to be installed on the server because of file dependencies. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
836993 How to obtain the latest service packs for Exchange Server 2003

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, the following services are restarted automatically when you apply this hotfix:
  • The Microsoft Exchange Information Store service
  • The Microsoft Exchange System Attendant service
  • The Microsoft Search service
  • The Internet Information Services (IIS) Admin service and all dependent services

Hotfix replacement information

This hotfix does not replace any other hotfixes.

Hotfix installation information

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows

After you install the hotfix, you have to create the Restrict View-Only Administrator Access Right registry entry on the Exchange server for this hotfix to work. If you do not create this registry entry, or if the registry setting is set to zero, View-Only Administrators will still be able to access mailbox contents in a mailbox store. To set the registry entry, follow these steps:
  1. Click Start, click Run, type Regedit, and then click OK.
  2. Locate the following registry subkey:
    HKEY_LOCAL_MACHINE\System\CCS\Services\MSExchangeIS\ParameterSystem
  3. On the Edit menu, point to New, and then click DWORD Value.
  4. In the details pane, type Restrict View Only Administrator Access Right, and then press ENTER.
  5. Right-click Restrict View Only Administrator Access Right, and then click Modify.
  6. In the Edit DWORD Value dialog box, under Base, click Decimal.
  7. In the Value data box, type the value 1, and then click OK.
  8. Close Registry Editor.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTime
Cdo.dll6.5.7655.2724,99213-Mar-200916:36
Cdoex.dll6.5.7655.23,971,58413-Mar-200919:10
Davex.dll6.5.7655.21,135,61613-Mar-200904:07
Excdo.dll6.5.7655.23,658,75213-Mar-200919:10
Exoledb.dll6.5.7655.22,621,44013-Mar-200919:07
Exosal.dll6.5.7655.270,14413-Mar-200918:56
Lsmexhc.dll6.5.7655.2143,87213-Mar-200916:37
Madfb.dll6.5.7655.2526,33613-Mar-200919:10
Mdbmsg.dll6.5.7655.23,384,83213-Mar-200917:07
Rtdsmcal.dll6.5.7655.240,96013-Mar-200917:01
Store.exe6.5.7655.25,267,45613-Mar-200918:58

↑ Back to the top


More information

For more information about administrative applications, visit the following Web site and see the "Determining the Type of Client Application" section and the "Determining the Type of User" section:

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: KB959745, kbfix, kbqfe, kbhotfixserver, kbhotfixrollup, kbsurveynew, kbautohotfix, kbexpertiseinter

↑ Back to the top

Article Info
Article ID : 959745
Revision : 1
Created on : 3/27/2009
Published on : 3/27/2009
Exists online : False
Views : 203