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Error message when you run the Chkdsk.exe utility to fix a corrupted volume on a Windows Server 2003-based computer: "Stop 0x00000024"


View products that this article applies to.

Symptoms

Consider the following scenario. You find a corrupted volume on a Windows Server 2003-based computer. You run the chkdsk /f command to fix the corrupted volume. In this scenario, the Windows Server 2003-based computer may restart unexpectedly, and you may receive a Stop error message that resembles the following:
Stop 0x00000024 ( parameter1 , parameter2 , parameter3 , parameter4 )
Notes
  • The results of the Stop error message may vary, depending on the system failure settings of the computer.
  • The parameter values of the Stop error message may vary, depending on the computer configuration.
  • Not all "STOP 0x00000024" error messages are caused by the problem that is described in this article.
Additionally, the following event is logged in the System log after this problem occurs:

Event type: Error
Event source: EventLog
Event category: None
Event ID: 6008
Date: Date
Time: Time
User: N/A
Computer: ComputerName
Description: The previous system shutdown at PreviousTime on PreviousDate was unexpected.

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Cause

This problem occurs because the Chkdsk.exe utility flushes the target volume. If the target volume is corrupted, NTFS marks the volume with a "dirty" flag. During this process, the Ntfs.sys driver may pass an incorrect stream control block (SCB) pointer to the system. This behavior causes the problem.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 (SP1) or Windows Server 2003 Service Pack 2 (SP2) installed. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 1, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Ntfs.sys5.2.3790.3246592,38413-Nov-200811:17x86
Windows Server 2003 with Service Pack 2, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Ntfs.sys5.2.3790.4409591,87213-Nov-200811:42x86
Windows Server 2003 with Service Pack 1, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Ntfs.sys5.2.3790.32461,886,20814-Nov-200803:34IA-64
Windows Server 2003 with Service Pack 2, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Ntfs.sys5.2.3790.44091,888,76814-Nov-200803:37IA-64
Windows Server 2003 with Service Pack 1, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Ntfs.sys5.2.3790.32461,127,42414-Nov-200803:33x64
Windows Server 2003 with Service Pack 2, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Ntfs.sys5.2.3790.44091,044,48014-Nov-200803:39x64
Windows XP x64-based versions with Service Pack 1
File nameFile versionFile sizeDateTimePlatform
Ntfs.sys5.2.3790.32461,127,42414-Nov-200803:33x64
Windows XP x64-based versions with Service Pack 2
File nameFile versionFile sizeDateTimePlatform
Ntfs.sys5.2.3790.44091,044,48014-Nov-200803:39x64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

After the Chkdsk.exe utility scans a corrupted disk, an error message that resembles the following is logged in the System event log:
Event Type: Error
Event Source: Ntfs
Event Category: (2)
Event ID: 55
Date: date
Time: time
User: N/A
Computer: computer name
Description: The file system structure on the disk is corrupt and unusable. Please run the chkdsk utility on the volume disk letter.

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Keywords: kbautohotfix, kbexpertiseinter, kbfix, kbbug, kbsurveynew, kbqfe, KB959608

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Article Info
Article ID : 959608
Revision : 2
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 281