Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

A VSS hardware snapshot database keeps growing with duplicated snapshot information when it is updated for snapshot creation/deletion in Windows Server 2008 or in Windows Vista SP1 systems


View products that this article applies to.

Symptoms

When you start multiple Volume Shadow Copy (VSS) requestor instances with VSS hardware provider to delete snapshots in Windows Server 2008 or Windows Vista SP1 systems, each VSS requestor instance may take an increasingly longer time to finish. Eventually, the VSS requestor instances fail. Additionally, the VSS hardware provider database increases with each duplicated snapshot.

↑ Back to the top


Cause

This problem occurs because the VSS service uses a Boolean member variable to track whether a set of snapshots must be loaded. However, access to this variable is not serialized. Therefore, when multiple calls access this variable at the same time, the snapshots are loaded repeatedly into the database. Therefore, the VSS hardware provider database keeps growing.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Important Windows Vista and Windows Server 2008 hotfixes are included in the same packages. However, only one of these products may be listed on the �Hotfix Request� page. To request the hotfix package that applies to both Windows Vista and Windows Server 2008, just select the product that is listed on the page.

Prerequisites

To apply this hotfix on Windows Vista-based computers, you must have Windows Vista SP1 installed. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack
�To�apply this hotfix on Windows Server 2008-based computers, you must have Windows Server 2008 RTM installed.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Vista and Windows Server 2008 file information notes

The MANIFEST files (.manifest) and MUM files (.mum) installed for each environment are listed separately. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files (attributes not listed) are signed with a Microsoft digital signature.
For all supported 32-bit versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Vssvc.exe6.0.6001.223031,055,74406-Nov-200812:59x86
For all supported 64-bit versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Vssvc.exe6.0.6001.223031,433,60006-Nov-200814:17x64
For all supported Itanium-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Vssvc.exe6.0.6001.223032,438,14406-Nov-200813:53IA-64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: kbsurveynew, kbautohotfix, kbexpertiseinter, kbfix, kbbug, kbqfe, KB959476

↑ Back to the top

Article Info
Article ID : 959476
Revision : 3
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 417