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FIX: You do not see any messages that pass through the ordered send port when you run some message queries in Health and Activity Tracking in BizTalk Server 2006 or in BizTalk Server 2006 R2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You use Microsoft BizTalk Server 2006 or Microsoft BizTalk Server 2006 R2.
  • You configure Ordered Delivery on a send port.
  • You run some message queries in Health and Activity Tracking (HAT).
In this scenario, you do not see any messages that pass through the ordered send port, even though the messages are in the live window period of the "DTA Purge and Archive" job.

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Cause

This issue occurs because of an error in the soft purge logic that is included in the Bts_tracking_logic.sql file. Because of this error in the soft purge logic, the "DTA Purge and Archive" job purges data from the dta_MessageInOutEvents table in the BizTalk Tracking (BizTalkDTADb) database even if the data was not archived.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have BizTalk Server 2006 or BizTalk Server 2006 R2 installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
BizTalk Server 2006
File nameFile versionFile sizeDateTimePlatform
Bts_tracking_logic.sqlNot applicable323,85617-Dec-200818:55Not applicable
BizTalk Server 2006 R2
File nameFile versionFile sizeDateTimePlatform
Bts_tracking_logic.sqlNot applicable325,15819-Jan-200923:58Not applicable

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about how to archive and purge, visit the following Microsoft Web site:For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbbiztalk2006r2sp1fix, kbbiztalk2006presp1fix, kbsurveynew, kbautohotfix, kbexpertiseinter, kbhotfixserver, kbqfe, KB959315

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Article Info
Article ID : 959315
Revision : 2
Created on : 2/6/2009
Published on : 2/6/2009
Exists online : False
Views : 440