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When you send a print job to an Internet Printer Protocol (IPP) print server from a Windows-based computer, the print job fails and never restarts


View products that this article applies to.

Symptoms

On a Windows-based computer, you send a print job to an Internet Printer Protocol (IPP) print server, such as a Hewlett-Packard (HP) JetDirect print server or a Web-based print server that is running Internet Information Services (IIS). In this case, the print job may fail and never restart.

This issue may occur in the following operating systems:
  • Windows XP
  • Windows Vista
  • Windows Server 2003
  • Windows Server 2008

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Cause

This issue occurs when multiple print jobs are sent to the IPP print server, and the print server is busy processing the first print job. In this case, the successive print jobs are lost or in the error state. However, the Windows-based client does not resend the print jobs. Therefore, the print jobs do not restart.

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Resolution

To resolve this issue, install hotfix 958910 on the Windows-based client. Additionally, if you are using an HP JetDirect print server, you must upgrade the HP Jetdirect firmware to the latest version. To upgrade the HP Jetdirect firmware, visit the following HP Web site:For more information, visit the following HP Web site: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

Hotfix information for Windows Vista and Windows Server 2008

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Important Windows Vista and Windows Server 2008 hotfixes are included in the same packages. However, only one of these products may be listed on the �Hotfix Request� page. To request the hotfix package that applies to both Windows Vista and Windows Server 2008, just select the product that is listed on the page.

Prerequisites

To apply this hotfix, you must have Windows Vista Service Pack 1 (SP1) or Windows Server 2008 installed on the computer.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

Registry information

To use this hotfix, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Server 2008 and Windows Vista file information note

The .manifest files and the .mum files that are installed in each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. These files and their associated .cat (security catalog) files are critical to maintaining the state of the updated component. The .cat files are signed with a Microsoft digital signature. The attributes of these security files are not listed.

For all supported x86-based versions of Windows Server 2008 and Windows Vista

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Inetpp.dll6.0.6001.22314122,36821-Nov-200804:34x86
Inetppui.dll6.0.6001.2231415,36021-Nov-200804:34x86
Wpnpinst.exe6.0.6001.2231439,42421-Nov-200804:34x86

For all supported x64-based versions of Windows Server 2008 and Windows Vista

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Inetpp.dll6.0.6001.22314156,16021-Nov-200805:41x64
Inetppui.dll6.0.6001.2231417,40821-Nov-200805:41x64
Wpnpinst.exe6.0.6001.2231447,10421-Nov-200805:41x64

For all supported Itanium-based versions of Windows Server 2008

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Inetpp.dll6.0.6001.22314350,72021-Nov-200805:54IA-64
Inetppui.dll6.0.6001.2231434,30421-Nov-200805:54IA-64
Wpnpinst.exe6.0.6001.22314120,83221-Nov-200805:48IA-64

Hotfix information for Windows XP

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows XP Service Pack 2 (SP2) or Windows XP Service Pack 3 (SP3) installed on the computer.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

Registry information

To use this hotfix, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows XP SP2, x86-based versions

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Inetpp.dll5.1.2600.348476,80025-Nov-200814:47x86

Windows XP SP3, x86-based versions

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Inetpp.dll5.1.2600.571676,80025-Nov-200819:05x86

Hotfix information for Windows Server 2003

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 SP1 or Windows Server 2003 SP2 installed on the computer.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

Registry information

To use this hotfix, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Server 2003 SP1, x86-based versions

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Inetpp.dll5.2.3790.325378,33625-Nov-200818:09x86

Windows Server 2003 SP2, x86-based versions

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Inetpp.dll5.2.3790.441778,33625-Nov-200818:34x86

Windows Server 2003 SP1, x64-based versions

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Inetpp.dll5.2.3790.3253156,16025-Nov-200817:05x64SP1Not Applicable
Winetpp.dll5.2.3790.325378,33625-Nov-200817:05x86SP1WOW

Windows Server 2003 SP2, x64-based versions

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Inetpp.dll5.2.3790.4417156,16025-Nov-200817:16x64SP2Not Applicable
Winetpp.dll5.2.3790.441778,33625-Nov-200817:16x86SP2WOW

Windows Server 2003 SP1, Itanium-based versions

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Inetpp.dll5.2.3790.3253223,23225-Nov-200817:05IA-64SP1Not Applicable
Winetpp.dll5.2.3790.325378,33625-Nov-200817:05x86SP1WOW

Windows Server 2003 SP2, Itanium-based versions

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Inetpp.dll5.2.3790.4417223,23225-Nov-200817:11IA-64SP2Not Applicable
Winetpp.dll5.2.3790.441778,33625-Nov-200817:11x86SP2WOW

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
307847� HOW TO: Connect to a Printer by Using a Web Browser in Windows XP
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

Additional file information for Windows Vista and Windows Server 2008

Additional files for all supported x86-based versions of Windows Vista and Windows Server 2008

Collapse this tableExpand this table
File namePackage_for_kb958910_client_1~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,367
Date (UTC)21-Nov-2008
Time (UTC)14:22
File namePackage_for_kb958910_client~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,430
Date (UTC)21-Nov-2008
Time (UTC)14:22
File namePackage_for_kb958910_server_0~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,417
Date (UTC)21-Nov-2008
Time (UTC)14:22
File namePackage_for_kb958910_server~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,430
Date (UTC)21-Nov-2008
Time (UTC)14:22
File nameX86_0b9788a53a36fbf499384019ffeb9f80_31bf3856ad364e35_6.0.6001.22314_none_1ed84161844cf02c.manifest
File versionNot Applicable
File size720
Date (UTC)21-Nov-2008
Time (UTC)14:22
File nameX86_microsoft-windows-p..rnetprinting-client_31bf3856ad364e35_6.0.6001.22314_none_8b553780e18555a7.manifest
File versionNot Applicable
File size13,313
Date (UTC)21-Nov-2008
Time (UTC)05:50

Additional files for all supported x64-based versions of Windows Vista and Windows Server 2008

Collapse this tableExpand this table
File nameAmd64_5dc17750b3e062d21b569dd8422e66c1_31bf3856ad364e35_6.0.6001.22314_none_c879d16b35e6b9a4.manifest
File versionNot Applicable
File size724
Date (UTC)21-Nov-2008
Time (UTC)14:22
File nameAmd64_microsoft-windows-p..rnetprinting-client_31bf3856ad364e35_6.0.6001.22314_none_e773d30499e2c6dd.manifest
File versionNot Applicable
File size16,179
Date (UTC)21-Nov-2008
Time (UTC)05:57
File namePackage_for_kb958910_client_1~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,375
Date (UTC)21-Nov-2008
Time (UTC)14:22
File namePackage_for_kb958910_client~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,438
Date (UTC)21-Nov-2008
Time (UTC)14:22
File namePackage_for_kb958910_server_0~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,425
Date (UTC)21-Nov-2008
Time (UTC)14:22
File namePackage_for_kb958910_server~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,438
Date (UTC)21-Nov-2008
Time (UTC)14:22

Additional files for all supported Itanium-based versions of Windows Server 2008

Collapse this tableExpand this table
File nameIa64_e4ca7a58f03132ae213a48afb25f3756_31bf3856ad364e35_6.0.6001.22314_none_0a56d42e66f26387.manifest
File versionNot Applicable
File size722
Date (UTC)21-Nov-2008
Time (UTC)14:22
File nameIa64_microsoft-windows-p..rnetprinting-client_31bf3856ad364e35_6.0.6001.22314_none_8b56db76e1835ea3.manifest
File versionNot Applicable
File size16,165
Date (UTC)21-Nov-2008
Time (UTC)06:25
File namePackage_for_kb958910_server_0~31bf3856ad364e35~ia64~~6.0.1.0.mum
File versionNot Applicable
File size1,421
Date (UTC)21-Nov-2008
Time (UTC)14:22
File namePackage_for_kb958910_server~31bf3856ad364e35~ia64~~6.0.1.0.mum
File versionNot Applicable
File size1,434
Date (UTC)21-Nov-2008
Time (UTC)14:22

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

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Keywords: kbautohotfix, kbexpertisebeginner, kbfix, kbsurveynew, kbqfe, kbhotfixserver, KB958910

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Article Info
Article ID : 958910
Revision : 1
Created on : 1/20/2009
Published on : 1/20/2009
Exists online : False
Views : 421