Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

It takes a long time to log on to a Windows Vista-based computer that has antivirus software installed, and you notice that the size of the Setupapi.app.log file is very large


View products that this article applies to.

Problem description

You have antivirus software installed on a Windows Vista-based computer. When you start the system, it takes a long time to log on to the computer. If you examine the Setupapi.app.log file in the %SystemRoot%\Inf folder, you notice that the file size is very large. Additionally, the size of the Setupapi.app.log file continues to grow every time that you start the computer.

Notes
  • Any log file of 5 megabytes (MB) or more is considered very large in this article's context.
  • Several Setupapi-related log files are mentioned in this article.

↑ Back to the top


Cause

This problem occurs because the verbose logging policy for the Setupapi.app.log file in Windows Vista is set to the most verbose setting (0x20000FFFF). Therefore, the logging information is very detailed, and it includes more than just error or warning information. This behavior causes unwanted interaction with the antivirus software because the log file is repeatedly opened and closed. Additionally, during system startup, the antivirus software may scan the Setupapi.app.log file. This causes the delay in the logon process.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Important Windows Vista and Windows Server 2008 hotfixes are included in the same packages. However, only one of these products may be listed on the �Hotfix Request� page. To request the hotfix package that applies to both Windows Vista and Windows Server 2008, just select the product that is listed on the page.

Prerequisites

To apply this hotfix on Windows Vista-based computer, you must have Windows Vista Service Pack 1 (SP1) installed.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack
No prerequisites are required for Windows Server 2008-based computers.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista and Windows Server 2008 file information notes

The MANIFEST files (.manifest) and MUM files (.mum) that are installed for each environment are listed separately. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files (attributes not listed) are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Expand.exe6.0.6001.2231352,73620-Nov-200808:48x86
Netmsg.dll6.0.6001.223132,04820-Nov-200808:45x86
Netrap.dll6.0.6001.2231314,84820-Nov-200808:49x86
Setupapi.dll6.0.6001.223131,591,29620-Nov-200808:49x86
Setupapi.mofNot Applicable3,68918-Dec-200721:40Not Applicable
For all supported x64-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Expand.exe6.0.6001.2231363,48820-Nov-200810:08x64
Netmsg.dll6.0.6001.223132,04820-Nov-200810:04x64
Netrap.dll6.0.6001.2231321,50420-Nov-200810:10x64
Setupapi.dll6.0.6001.223131,923,07220-Nov-200810:10x64
Setupapi.mofNot Applicable3,68918-Dec-200721:40Not Applicable
For all supported IA-64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Expand.exe6.0.6001.22313117,24820-Nov-200810:18IA-64
Netmsg.dll6.0.6001.223132,04820-Nov-200810:12IA-64
Netrap.dll6.0.6001.2231344,54420-Nov-200810:31IA-64
Setupapi.dll6.0.6001.223133,080,19220-Nov-200810:34IA-64
Setupapi.mofNot Applicable3,68918-Dec-200721:40Not Applicable

↑ Back to the top


Workaround

To work around this problem, you must remove or adjust a value for a registry entry. We can adjust this value for you. To have us do this, go to the "Fix it for me" section. If you would rather remove or adjust the value for a registry entry yourself, go to the "Let me fix it myself" section.

Fix it for me

To adjust the value for a registry entry automatically, click the Fix this problem link. Then click Run in the File Download dialog box, and follow the steps in this wizard.

Fix this problem
Microsoft Fix it 50162



Note this wizard may be in English only; however, the automatic fix also works for other language versions of Windows.

Note if you are not on the computer that has the problem, save the Fix it solution to a flash drive or a CD and then run it on the computer that has the problem.

Now go to the "Did this fix the problem?" section.

Let me fix it myself

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows
To fix this problem yourself, you must delete or adjust the value of the following registry entry:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Setup\LogLevel
To do this, follow these steps:
  1. Click Start, type regedit in the Start Search box, and then press ENTER.

    If you are prompted for an administrator password or for confirmation, type the password, or provide confirmation.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Setup
  3. To delete the LogLevel registry entry, right-click LogLevel, and then click Delete.
  4. To adjust the value of the LogLevel registry entry, follow these steps:
    1. Double-click the LogLevel registry entry.
    2. In the Edit DWORD (32-bit) Value window, select Hexadecimal in the Base pane.
    3. In the Value data box, type 0x00000020.
    4. Click OK.
  5. Exit Registry Editor.

↑ Back to the top


Did this fix the problem?

Check whether the problem is fixed. If it is fixed, you are finished with this article. If it is not fixed, you can contact support.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

Additional file information for Windows Server 2008 and for Windows Vista

Additional files for all supported x86-based versions of Windows Server 2008 and of Windows Vista
File namePackage_for_kb958909_client_1~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,367
Date (UTC)20-Nov-2008
Time (UTC)18:09
File namePackage_for_kb958909_client~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,431
Date (UTC)20-Nov-2008
Time (UTC)18:09
File namePackage_for_kb958909_sc_0~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,422
Date (UTC)20-Nov-2008
Time (UTC)18:09
File namePackage_for_kb958909_sc~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,423
Date (UTC)20-Nov-2008
Time (UTC)18:09
File namePackage_for_kb958909_server_0~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,425
Date (UTC)20-Nov-2008
Time (UTC)18:09
File namePackage_for_kb958909_server~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,431
Date (UTC)20-Nov-2008
Time (UTC)18:09
File namePackage_for_kb958909_winpesrv_0~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,422
Date (UTC)20-Nov-2008
Time (UTC)18:09
File namePackage_for_kb958909_winpesrv~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,430
Date (UTC)20-Nov-2008
Time (UTC)18:09
File nameX86_microsoft-windows-basic-misc-tools_31bf3856ad364e35_6.0.6001.22313_none_17de88f9d88e9185.manifest
File versionNot Applicable
File size7,740
Date (UTC)20-Nov-2008
Time (UTC)09:43
File nameX86_microsoft-windows-setupapi_31bf3856ad364e35_6.0.6001.22313_none_35772b39df60dc63.manifest
File versionNot Applicable
File size18,306
Date (UTC)20-Nov-2008
Time (UTC)09:40
Additional files for all supported x64-based versions of Windows Server 2008 and of Windows Vista
File nameAmd64_00926cf4aed405636e833a7160d63e7e_31bf3856ad364e35_6.0.6001.22313_none_b85dc478f1fb1d51.manifest
File versionNot Applicable
File size708
Date (UTC)20-Nov-2008
Time (UTC)18:09
File nameAmd64_479e4fdc049e650366bc0676c84b5519_31bf3856ad364e35_6.0.6001.22313_none_1a4722aeb209057c.manifest
File versionNot Applicable
File size700
Date (UTC)20-Nov-2008
Time (UTC)18:09
File nameAmd64_9803efa5477f2219ad2b1f9aa344b35f_31bf3856ad364e35_6.0.6001.22313_none_19b2920eab68f932.manifest
File versionNot Applicable
File size1,040
Date (UTC)20-Nov-2008
Time (UTC)18:09
File nameAmd64_a2cc7aa8b937ae51295e645c8e2620ef_31bf3856ad364e35_6.0.6001.22313_none_fb9b2ac0620cdcc7.manifest
File versionNot Applicable
File size1,056
Date (UTC)20-Nov-2008
Time (UTC)18:09
File nameAmd64_microsoft-windows-basic-misc-tools_31bf3856ad364e35_6.0.6001.22313_none_73fd247d90ec02bb.manifest
File versionNot Applicable
File size7,758
Date (UTC)20-Nov-2008
Time (UTC)11:16
File nameAmd64_microsoft-windows-setupapi_31bf3856ad364e35_6.0.6001.22313_none_9195c6bd97be4d99.manifest
File versionNot Applicable
File size18,362
Date (UTC)20-Nov-2008
Time (UTC)11:13
File namePackage_for_kb958909_client_1~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,375
Date (UTC)20-Nov-2008
Time (UTC)18:09
File namePackage_for_kb958909_client~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,439
Date (UTC)20-Nov-2008
Time (UTC)18:09
File namePackage_for_kb958909_sc_0~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,430
Date (UTC)20-Nov-2008
Time (UTC)18:09
File namePackage_for_kb958909_sc~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,431
Date (UTC)20-Nov-2008
Time (UTC)18:09
File namePackage_for_kb958909_server_0~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,433
Date (UTC)20-Nov-2008
Time (UTC)18:09
File namePackage_for_kb958909_server~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,439
Date (UTC)20-Nov-2008
Time (UTC)18:09
File namePackage_for_kb958909_winpesrv_0~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,430
Date (UTC)20-Nov-2008
Time (UTC)18:09
File namePackage_for_kb958909_winpesrv~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,438
Date (UTC)20-Nov-2008
Time (UTC)18:09
Additional files for all supported IA-64-based versions of Windows Server 2008
File nameIa64_139a7933a56687d715f9e8d8fe4a07f5_31bf3856ad364e35_6.0.6001.22313_none_5cfdf7ecc30d355d.manifest
File versionNot Applicable
File size1,054
Date (UTC)20-Nov-2008
Time (UTC)18:09
File nameIa64_2f260bdadbbab130d43a7e7971a4d078_31bf3856ad364e35_6.0.6001.22313_none_a070cb6c48fcc3a5.manifest
File versionNot Applicable
File size698
Date (UTC)20-Nov-2008
Time (UTC)18:09
File nameIa64_7ef72344d02a9f43fcc4e6da29a63426_31bf3856ad364e35_6.0.6001.22313_none_8ed5ef2c999c0d31.manifest
File versionNot Applicable
File size706
Date (UTC)20-Nov-2008
Time (UTC)18:09
File nameIa64_ce93e7d9933a9f68b4750b36e28c05eb_31bf3856ad364e35_6.0.6001.22313_none_ace5d8aa23f6c966.manifest
File versionNot Applicable
File size1,038
Date (UTC)20-Nov-2008
Time (UTC)18:09
File nameIa64_microsoft-windows-basic-misc-tools_31bf3856ad364e35_6.0.6001.22313_none_17e02cefd88c9a81.manifest
File versionNot Applicable
File size7,749
Date (UTC)20-Nov-2008
Time (UTC)12:18
File nameIa64_microsoft-windows-setupapi_31bf3856ad364e35_6.0.6001.22313_none_3578cf2fdf5ee55f.manifest
File versionNot Applicable
File size18,334
Date (UTC)20-Nov-2008
Time (UTC)12:15

↑ Back to the top


Keywords: kbmsifixme, kbfixme, kbautohotfix, kbexpertiseinter, kbfix, kbbug, kbsurveynew, kbqfe, KB958909

↑ Back to the top

Article Info
Article ID : 958909
Revision : 4
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 330