Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

A Windows Server 2003-based computer restarts unexpectedly and you receive a Stop error message during the terminal session logoff process: "0x0000008E KERNEL_MODE_EXCEPTION_NOT_HANDLED"


View products that this article applies to.

Symptoms

When a client computer logs off a Windows Server 2003 Terminal Server session, the terminal server may restart unexpectedly. Additionally, the terminal server user receives a Stop error message. This Stop error message resembles the following:
STOP 0x0000008E ( parameter1 , parameter2 , parameter3 , parameter4 )
KERNEL_MODE_EXCEPTION_NOT_HANDLED
Notes
  • The parameters in this Stop error message may vary, depending on the configuration of the computer.
  • Not all "0x0000008E" Stop error messages are caused by this problem.

↑ Back to the top


Cause

This problem occurs because of a race condition in the win32k.sys module. When the race condition occurs, the system tries to change the owner thread for an object. However, the owner thread does not exist. Therefore, the system triggers a stop code 0x0000008E error.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 (SP1) or Windows Server 2003 Service Pack 2 (SP2) installed. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 1, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Gdi32.dll5.2.3790.3091285,18418-Feb-200813:14x86SP1
Win32k.sys5.2.3790.32381,859,58431-Oct-200814:05x86SP1
Windows Server 2003 with Service Pack 2, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Win32k.sys5.2.3790.44011,849,85631-Oct-200816:13x86
Windows Server 2003 with Service Pack 1, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Gdi32.dll5.2.3790.3091910,84801-Nov-200800:48IA-64SP1Not Applicable
Win32k.sys5.2.3790.32385,562,88001-Nov-200800:48IA-64SP1Not Applicable
Wgdi32.dll5.2.3790.3091288,76801-Nov-200800:48x86SP1WOW
Windows Server 2003 with Service Pack 2, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Win32k.sys5.2.3790.44015,568,51201-Nov-200800:53IA-64
Windows Server 2003 with Service Pack 1, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Gdi32.dll5.2.3790.3091619,00801-Nov-200800:48x64SP1Not Applicable
Win32k.sys5.2.3790.32384,549,63201-Nov-200800:48x64SP1Not Applicable
Wgdi32.dll5.2.3790.3091288,76801-Nov-200800:48x86SP1WOW
Windows Server 2003 with Service Pack 2, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Win32k.sys5.2.3790.44014,542,97601-Nov-200800:54x64
Windows XP x64-based versions with Service Pack 1
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Gdi32.dll5.2.3790.3091619,00801-Nov-200800:48x64SP1Not Applicable
Win32k.sys5.2.3790.32384,549,63201-Nov-200800:48x64SP1Not Applicable
Wgdi32.dll5.2.3790.3091288,76801-Nov-200800:48x86SP1WOW
Windows XP x64-based versions with Service Pack 2
File nameFile versionFile sizeDateTimePlatform
Win32k.sys5.2.3790.44014,542,97601-Nov-200800:54x64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

Call stack output

The following is a sample debug log:
6: kd> .bugcheck
Bugcheck code 0000008E
Arguments c0000005 bf83d424 8b9a7b84 00000000

6: kd> .trap 0xffffffff8b9a7b84
ErrCode = 00000000
eax=be132044 ebx=bc10d4b8 ecx=00000000 edx=84b111a0 esi=bc428b80 edi=00000000
eip=bf83d424 esp=8b9a7bf8 ebp=8b9a7c04 iopl=0 nv up ei pl nz na pe nc
cs=0008 ss=0010 ds=0023 es=0023 fs=0030 gs=0000 efl=00010206
win32k!HMChangeOwnerThread+0x36:
bf83d424 8b492c mov ecx,dword ptr [ecx+2Ch] ds:0023:0000002c=????????

6: kd> kb
ChildEBP RetAddr Args to Child
8b9a7c04 bf8b7f41 bc428b80 00000000 bf9b3b88 win32k!HMChangeOwnerThread+0x36
8b9a7c1c bf8b8fe9 bc10d4b8 84a94a90 00000000 win32k!MarkThreadsObjects+0x47
8b9a7c64 bf8b76bb 00000001 8b9a7c8c bf8b8518 win32k!xxxDestroyThreadInfo+0x4b1
8b9a7c70 bf8b8518 84a94a90 00000001 00000000 win32k!UserThreadCallout+0x4b
8b9a7c8c 8094c2ac 84a94a90 00000001 84a94a90 win32k!W32pThreadCallout+0x3a
8b9a7d18 8094c63f 00000000 00000000 84a94a90 nt!PspExitThread+0x3b2
8b9a7d30 8094c991 84a94a90 00000000 00000001 nt!PspTerminateThreadByPointer+0x4b
8b9a7d54 8088978c fffffffe 00000000 0090ffdc nt!NtTerminateThread+0x71
8b9a7d54 7c9785ec fffffffe 00000000 0090ffdc nt!KiFastCallEntry+0xfc
0090ffdc 00000000 00000000 00000000 00000000 0x7c9785ec
6: kd> dd win32k!gptiRit L1
bf9b39c8 00000000              <--------- win32!gpiRit is NULL.

↑ Back to the top


Keywords: kbautohotfix, kbexpertiseinter, kbfix, kbbug, kbqfe, KB958820

↑ Back to the top

Article Info
Article ID : 958820
Revision : 2
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 288