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Event ID 12 is logged in the System log when you back up or compact a Hyper-V virtual hard disk on a Windows Server 2008-based computer


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You install the Hyper-V role on a Windows Server 2008-based computer.
  • You create a virtual machine.
  • You back up or compact the virtual hard disk.
In this scenario, an error that resembles the following may be logged in the System log when you back up a virtual hard disk. For example, this error may be logged when you use the Windows Server Backup feature to back up the virtual hard disk.

Note This problem can occur if the virtual machine is running when you perform the backup.
Log Name: System
Source: PlugPlayManager
Date: datetime
Event ID: 12
Task Category: None
Level: Error
Keywords: Classic
User: N/A
Computer: computer name
Description:
The device 'MSFT Virtual HD SCSI Disk Device' (SCSI\Disk&Ven_MSFT&Prod_Virtual_HD\GUID) disappeared from the system without first being prepared for removal.

Additionally, the following error may be logged in the System log when you use the Compact action in the Edit Virtual Hard Disk Wizard to compact a virtual hard disk:
Log Name: System
Source: PlugPlayManager
Date: datetime
Event ID: 12
Task Category: None
Level: Error
Keywords: Classic
User: N/A
Computer: computer name
Description:
The device 'Storage miniport driver' (VMBUS\{GUID}\GUID}) disappeared from the system without first being prepared for removal.

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Cause

This problem occurs when the "MSFT Virtual HD SCSI Disk Device" device or the "Storage miniport driver" device is removed from the system after the backup or compact actions are finished.

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Workaround

You can safely ignore this error message. This error message does not affect the performance of your computer.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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References

For more information about Hyper-V technology, visit the following Microsoft TechNet Web site:

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Keywords: KB958669, kbtshoot, kbprb

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Article Info
Article ID : 958669
Revision : 1
Created on : 10/21/2008
Published on : 10/21/2008
Exists online : False
Views : 415