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Incorrect results are returned when you use the Reports feature in File Server Resource Manager to search for files whose names include specific DBCS characters in Windows Server 2003 R2


View products that this article applies to.

Symptoms

On a computer that is running Windows Server 2003 R2, you use the Reports feature in File Server Resource Manager to search for files whose names include specific double-byte character set (DBCS) characters. However, in this scenario, incorrect results are returned.

This problem occurs when the search conditions contain a combination of wildcard characters and DBCS characters in the first part of the file name field. For example, when you search for files against the following file name criteria, all files are unexpectedly returned:
  • ?*.*
  • *?
  • ?*.*
Note The question mark in the third file name criteria is the Japanese character "?" instead of an English-language question mark.

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Cause

The File Server Resource Manager Reports feature does not correctly handle DBCS characters. Instead, it supports only ANSI characters.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2003 R2.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 R2 with Service Pack 1, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Srmreports.dll5.2.3790.3225303,10411-Oct-200806:11x86SP1
Srmscan.dll5.2.3790.3225235,52011-Oct-200806:11x86SP1
Windows Server 2003 R2 with Service Pack 2, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Srmreports.dll5.2.3790.4388303,10411-Oct-200805:58x86SP2
Srmscan.dll5.2.3790.4388235,52011-Oct-200805:58x86SP2
Windows Server 2003 R2 with Service Pack 1, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Srmreports.dll5.2.3790.3225303,10411-Oct-200804:03x86SP1
Srmscan.dll5.2.3790.3225366,59211-Oct-200804:03x64SP1
Windows Server 2003 R2 with Service Pack 2, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Srmreports.dll5.2.3790.4388303,10411-Oct-200804:23x86SP2
Srmscan.dll5.2.3790.4388366,59211-Oct-200804:23x64SP2

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbexpertiseinter, kbbug, kbfix, kbqfe, KB958506

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Article Info
Article ID : 958506
Revision : 2
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 366