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The physical video memory capacity is displayed incorrectly in Windows Vista and in Windows Server 2008 if the graphics adapter's physical video memory is at least 4 GB


View products that this article applies to.

Symptoms

A Windows Vista-based or Windows Server 2008-based computer uses a graphics adapter that has at least 4 gigabytes (GB) of physical video memory. After you start the computer, the physical video memory capacity is displayed correctly on the screen during the Power-On Self Test (POST) stage. However, after you log on to the system, the system incorrectly reports the physical video memory capacity.

This incorrect information appears in different user interfaces. For example, when you view the adapter information in the Display Settings item in Control Panel for a graphics adapter that has 4 GB of physical video memory, the Dedicated Video Memory section shows only 0 megabytes (MB).

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Cause

This problem occurs because some APIs represent the video memory in 32-bit values instead of in 64-bit values.

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Resolution

Note The following hotfix is only for 64-bit versions of Windows. No hotfix for�32-bit versions of Windows is available or expected.�

This hotfix only corrects the incorrect physical graphics memory information that appears in the Display Settings item in Control Panel. Other user interfaces, such as the MsInfo32.exe interface, are not changed by this hotfix and continue to show inaccurate information.

Hotfix information

Important Windows Vista and Windows Server 2008 hotfixes are included in the same packages. However, only one of these products may be listed on the �Hotfix Request� page. To request the hotfix package that applies to both Windows Vista and Windows Server 2008, just select the product that is listed on the page.

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix on a Windows Vista-based computer, you must have Windows Vista Service Pack 1 installed on the computer. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791� How to obtain the latest Windows Vista service pack
No prerequisites are required for Windows Server 2008-based computers.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Vista and Windows Server 2008 file information notes

  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    Collapse this tableExpand this table
    VersionProductMilestoneService branch
    6.0.6000.16xxxWindows VistaRTMGDR
    6.0.6000.20xxxWindows VistaRTMLDR
    6.0.6001.18xxxWindows Vista SP1 and Windows Server 2008 SP1SP1GDR
    6.0.6001.22xxxWindows Vista SP1 and Windows Server 2008 SP1SP1LDR
  • Service Pack 1 is integrated into Windows Server 2008.
  • The .manifest files and the .mum files that are installed in each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. These files and their associated .cat (security catalog) files are critical to maintaining the state of the updated component. The .cat files are signed with a Microsoft digital signature. The attributes of these security files are not listed.
For all supported x64-based versions of Windows Server 2008 and Windows Vista
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Deskadp.dll6.0.6001.2229949,66431-Oct-200805:00x64
Themeui.dll6.0.6001.22299688,64031-Oct-200805:00x64
For all supported Itanium-based versions of Windows Server 2008
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Deskadp.dll6.0.6001.2229972,70431-Oct-200804:54IA-64
Themeui.dll6.0.6001.222991,064,96031-Oct-200804:55IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

To verify the video memory information, follow these steps:
  1. Right-click the desktop, and then click Personalize.
  2. Click Display Settings, and then click Advanced Settings.
  3. On the Adapter tab, the Dedicated Video Memory section indicates the physical video memory capacity.
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbexpertisebeginner, kbautohotfix, kbsurveynew, kbbug, kbfix, kbqfe, KB958360

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Article Info
Article ID : 958360
Revision : 2
Created on : 10/23/2010
Published on : 10/23/2010
Exists online : False
Views : 246