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The logoff process may take a long time when a user makes a terminal session from a Windows Server 2003 terminal server in a trusted domain, and the terminal service roaming profiles are used


View products that this article applies to.

Symptoms

Consider the following scenario:
  • Terminal Service roaming profiles are configured for users in a domain.
  • These users log on to a Windows Server 2003-based terminal server that is located in a trusted domain.
  • Terminal servers in the trusted domain cannot access the roaming profiles of the users. For example, a one-way trust relationship is made between both domains or the access is blocked by firewall.
In this scenario, it may take a long time for these users to log off from terminal sessions. For example, it may take 15 minutes for these users to log off from terminal sessions.

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Cause

This problem occurs because the Windows Server 2003 logoff process incorrectly performs a roaming profile check when a local user profile is used.

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Resolution

To resolve this problem, install the following hotfix. After you install this hotfix, the logoff process will bypass the roaming user profile if a local user profile is used.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 (SP1) or Windows Server 2003 Service Pack 2 (SP2) installed. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 1, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Userenv.dll5.2.3790.3227790,52814-Oct-200814:43x86
Windows Server 2003 with Service Pack 2, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Userenv.dll5.2.3790.4390780,80014-Oct-200814:37x86
Windows Server 2003 with Service Pack 1, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Userenv.dll5.2.3790.32271,563,64814-Oct-200812:42IA-64SP1Not Applicable
Wuserenv.dll5.2.3790.3227790,52814-Oct-200812:42x86SP1WOW
Windows Server 2003 with Service Pack 2, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Userenv.dll5.2.3790.43901,564,16014-Oct-200812:47IA-64SP2Not Applicable
Wuserenv.dll5.2.3790.4390780,80014-Oct-200812:48x86SP2WOW
Windows Server 2003 with Service Pack 1, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Userenv.dll5.2.3790.32271,070,59214-Oct-200812:42x64SP1Not Applicable
Wuserenv.dll5.2.3790.3227790,52814-Oct-200812:42x86SP1WOW
Windows Server 2003 with Service Pack 2, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Userenv.dll5.2.3790.43901,071,10414-Oct-200812:50x64SP2Not Applicable
Wuserenv.dll5.2.3790.4390780,80014-Oct-200812:50x86SP2WOW

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Workaround

To work around this problem, make sure that the problematic terminal server can access the server that stores the roaming profile.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: kbautohotfix, kbexpertiseinter, kbfix, kbbug, kbqfe, KB958246

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Article Info
Article ID : 958246
Revision : 2
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 210