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FIX: Event ID 5740 is logged in the Application log when you use an FTP adapter in BizTalk Server to receive files from an empty directory on an FTP server


View products that this article applies to.

Symptoms

Consider the following scenario in Microsoft BizTalk Server:
  • You configure an FTP adapter to receive files from a supported FTP server, as described in Microsoft Knowledge Base (KB) article 841478. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
    841478 The operating systems that are supported by the BizTalk Server 2006 FTP adapter and by the BizTalk Server 2004 FTP adapter
  • The remote directory on the FTP server is empty.
In this scenario, an event that resembles the following is logged repeatedly in the Application log:


Event Type: Warning
Event Source: BizTalk Server 2006
Event Category: BizTalk Server 2006
Event ID: 5740
Description:
The adapter "FTP" raised an error message. Details "A failure occurred when parsing the remote folder listing."



This issue typically occurs after the FTP adapter sends a LIST command to the FTP server, and then the FTP server returns the following error message:

550 No data sets found

Note This message indicates that no files are found on the remote directory.

When this issue occurs, the Application log is filled with these unnecessary 5740 events. This issue makes it difficult to identify other 5740 events that may indicate other issues.

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Cause

The issue occurs because the FTP adapter does not correctly parse the "550 No data sets found" message.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have BizTalk Server 2004, BizTalk Server 2006, or BizTalk Server 2006 R2 installed to apply the corresponding hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

For BizTalk Server 2004

File nameFile versionFile sizeDateTimePlatform
XceedFtpBizTalk.dll3.0.7451.0274,78407-Jun-200916:53x86
Interop.xceedftplib.dll3.0.7451.059,24007-Jun-200916:53x86
Microsoft.biztalk.coreadapter.dll3.0.7451.0128,88007-Jun-200916:53x86
Microsoft.biztalk.coreadaptermgmt.dll3.0.7451.096,12007-Jun-200916:53x86

For BizTalk Server 2006

File nameFile versionFile sizeDateTimePlatform
XceedFtpBizTalk.dll3.5.1770.0301,91214-Nov-200823:22x86
Interop.xceedftplib.dll3.5.1770.060,25614-Nov-200823:21x86
Microsoft.biztalk.coreadapter.dll3.5.1770.097,14414-Nov-200823:21x86
Microsoft.biztalk.coreadaptermgmt.dll3.5.1770.0105,34414-Nov-200823:21x86
Microsoft.biztalk.webservices.serverproxy.dll3.5.1770.052,11214-Nov-200823:21x86

For BizTalk Server 2006 R2

File nameFile versionFile sizeDateTimePlatform
Interop.xceedftplib.dll3.6.1493.260,25614-Nov-200821:29x86
Microsoft.biztalk.coreadapter.dll3.6.1493.2101,24014-Nov-200821:29x86
Microsoft.biztalk.coreadaptermgmt.dll3.6.1493.2105,34414-Nov-200821:29x86
Microsoft.biztalk.webservices.serverproxy.dll3.6.1493.252,11214-Nov-200821:29x86
Xceedftpbiztalk.dll3.6.1493.2302,42414-Nov-200821:30x86

Note Because of file dependencies, the most recent hotfix that contains these files may also contain additional files.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about the FTP adapter, visit the following Microsoft Web site:For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbbiztalk2006r2sp1fix, kbautohotfix, kbbiztalk2006presp1fix, kbbtsadapters, kbexpertiseinter, kbhotfixserver, kbqfe, KB958235

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Article Info
Article ID : 958235
Revision : 2
Created on : 7/28/2009
Published on : 7/28/2009
Exists online : False
Views : 550