Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: The rules engine tables are not being purged when you use BizTalk Server


View products that this article applies to.

Symptoms

When you use Microsoft BizTalk Server, you may find the rules engine tables are not being purged. Therefore, the rule engine database will continuously grow, even if you have configured the DTA Purge and Archive Job correctly.

Note By default, the rule engine database is named BizTalkRuleEngineDb. This problem could lead to slow performance in Health and Activity Tracking (HAT) queries.

↑ Back to the top


Cause

This problem occurs because of an error in the soft purge logic that is included in the Bts_tracking_logic.sql file. Because of this problem, none of the rules engine tables in the DTA database are purged.

↑ Back to the top


Resolution

Hotfix information

There are two versions of this hotfix:
  • Microsoft BizTalk Server 2004
  • Microsoft BizTalk Server 2006 R2
A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have BizTalk Server 2004 Service Pack 2 installed to apply the BizTalk 2004 version of this hotfix. You must have BizTalk Server 2006 R2 installed to apply the BizTalk 2006 R2 version of this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Microsoft BizTalk Server 2004
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Bts_tracking_logic.sqlNot applicable259,23831-Oct-200816:50Not applicable
Microsoft BizTalk Server 2006 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Bts_tracking_logic.sqlNot applicable325,00631-Oct-200816:18Not applicable
Note Because of file dependencies, the most recent hotfix that contains these files may also contain additional files.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about archiving and purging in BizTalk Server 2004, visit the following Microsoft Web site: For more information about archiving and purging in BizTalk Server 2006 R2, visit the following Microsoft Web site: For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbbiztalk2006r2sp1fix, kbbiztalk2004presp3fix, kbsurveynew, kbautohotfix, kbexpertiseinter, kbhotfixserver, kbqfe, KB958211

↑ Back to the top

Article Info
Article ID : 958211
Revision : 2
Created on : 4/17/2009
Published on : 4/17/2009
Exists online : False
Views : 374