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Error code when you use the Windows Update or Microsoft Update Web site to install updates: "0x8007066A"


View products that this article applies to.

Symptoms

When you try to install updates from the Windows Update or Microsoft Update Web site, you receive the following error code:
0x8007066A

Important:
If you receive error 0x8007066A when installing .Net Framework Updates try the steps listed in the following KB article before following the steps below to resolve your issue:
2507641 Error code "0x8007066A" when you use the Windows Update or Microsoft Update Web site to install .Net Framework updates

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Cause

This issue occurs if Windows Update or Microsoft Update determines that there are issues that involve installation prerequisites.

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Resolution

To resolve this issue, use the following methods. Start by using Method 1. If Method 1 does not resolve the issue, go to Method 2.

Method 1: Download and install the update manually

To manually download and install updates, follow these steps:
  1. Visit the following Microsoft Update Web site:
  2. Click Review your updated history to view the update history and to examine the error message to determine the update that you want to install.
  3. Visit the following Microsoft Web site:
  4. Type the Knowledge Base (KB) article number in the search window on the Downloads page, and then click GO.

    For example, if the KB article number that is listed for the update is KB123456, type 123456 in the search box, and then click GO.
  5. In the Search Results list, locate the KB article that you searched for, and then browse to that article.
  6. Search through the KB article, and then click the link that resembles the following:
    Download the package now
    Note If you are prompted to "validate Windows," follow the instructions to validate Windows, and then continue with the download.
  7. Click Download, and then click Save in the File Download dialog box.
  8. In the Save in list, click Desktop, and then click Save.
  9. On your desktop, locate the file that you downloaded, and then double-click the file to install the update.

    Note If the update is unsuitable for your computer, the installation of the update may still fail.

Method 2: Enable Microsoft Installer logging, and then contact Microsoft Support

If Method 1 does not resolve the issue, you should contact Microsoft Support for help. To save time in resolving the issue, you can enable and generate a Microsoft installer log before you contact Microsoft Support. To enable Microsoft Installer logging and to generate the log file, follow these steps.

For computers that are running Windows 2000, Windows XP, or Windows Server 2003

  1. Click Start, click Run, type notepad, and then click OK.
  2. Type the following command lines into the Notepad window:
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer]
    "Logging"=dword:voicewarmupx
    "Debug"=dword:00000007
    
  3. On the File menu, click Save As.
  4. Select the Desktop option from the Save in drop-down list.
  5. Type LoggingOn.reg in the File name box, select the All Files option from the Save as type drop-down list, and then click Save.
  6. On the desktop, double-click the LoggingOn.reg file to add the registry keys to the Windows registry
  7. Click OK on the successful install dialog box.
  8. Try to install the update again to capture the additional error information in the Microsoft Installer .log file.
Note Collecting these logs can take several minutes and the update process may seem not to be functioning correctly, please take the necessary time for the process to finish.

Important As Soon As Windows Update or Microsoft Update has finished, you should disable Microsoft Installer logging, leaving logging enabled can require too much time every time that you install updates, slow down your computer and create large log files that require large amounts of disk space.

To disable Microsoft Installer logging, follow these steps:
  1. Click Start, click Run, type notepad, and then click OK.
  2. Type the following command lines into the opened Notepad window:
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer]
    "Logging"=-
    "Debug"=-
  3. On the File menu, click Save As.
  4. In the Save in list, click Desktop.
  5. In the File name box, type LoggingOn.reg, click All Files in the Save as type list, and then click Save.
  6. On the desktop, double-click the LoggingOn.reg file to remove the registry values from the Windows registry.
  7. When you are prompted with the information that the operation succeeded, click OK.
  8. Delete the LoggingOn.reg and LoggingOff.reg files from the desktop.
Contact Microsoft Support for help, and reference this KB article when you speak to the support agent. For more information about how to contact Microsoft Support, visit the following Microsoft Web site:

For computers that are running Windows Vista and Windows Server 2008

  1. Click Start
    , and then type notepad in the Start Search box.
  2. In the Programs list, click Notepad.
  3. Type the following command lines into the Notepad window:
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer]
    "Logging"=dword:voicewarmupx
    "Debug"=dword:00000007
  4. On the File menu, click Save As.
  5. In the Save in list, click Desktop.
  6. In the File name box, type LoggingOn.reg, click All Files in the Save as type list, and then click Save.
  7. On the desktop, double-click the LoggingOn.reg file to add the registry values to the Windows registry.

    If you are prompted for an administrator password or for confirmation, type the password, or click Continue.
  8. In the confirmation dialog box, click Yes, and then click OK.
  9. Try to install the update again to capture the additional error information in the Microsoft Installer .log file.
Note Collecting these logs can take several minutes, and the update process may seem not to be functioning correctly. Please take the necessary time for the process to finish.

Important As soon as Windows Update or Microsoft Update process has finished, disable Microsoft Installer logging. If you leave logging enabled, this will slow down your computer and create large log files that require large amounts of disk space every time that you install updates.

To disable Microsoft Installer logging, follow these steps:
  1. Click Start
    , and then type notepad in the Start Search box.
  2. In the Programs list, click Notepad.
  3. Type the following command lines into the Notepad window:
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer]
    "Logging"=-
    "Debug"=-
  4. On the File menu, click Save As.
  5. In the Save in list, click Desktop.
  6. In the File name box, type LoggingOff.reg, click All Files in the Save as type list, and then click Save.
  7. On the desktop, double-click the LoggingOff.reg file to remove the registry values from the Windows registry.

    If you are prompted for an administrator password or for confirmation, type the password, or click Continue.
  8. In the confirmation dialog box, click Yes, and then click OK.
  9. Delete the LoggingOn.reg and LoggingOff.reg files from the desktop.
Contact Microsoft Support for help, and reference this KB article when you speak to the support agent. For more information about how to contact Microsoft Support, visit the following Microsoft Web site:

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More information

Typically, the Microsoft Installer log file starts with �msi,� ends with a �.log� file name extension, and has a group characters in between. For example, the Microsoft Installer log has a file name that resembles the following:
msib3a6g.log
This file can be found in the following locations.

On computers that are running Windows 2000, Windows XP, or Windows Server 2003

The installer log is located in the following directory:
C:\Documents and Settings\ {UserName} \Local Settings\Temp
To open this directory, click Start, click Run, type %temp%, and then click OK.

Note This information assumes that Windows is installed in the default location, drive C. If this is not the case, revise the drive letter to match the drive letter of your installation drive.

On computers that are running Windows Vista or Windows Server 2008

The installer log is located in the following directory:
C:\Users\{UserName\AppData\Local\Temp
To open this directory, click Start
, type %temp% in the Start Search box, and then press ENTER.

Note This information assumes that Windows is installed in the default location, drive C. If this is not the case, revise the drive letter to match the drive letter of your installation drive.

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References

For more information about how to enable Microsoft Installer logging, click the following article number to view the article in the Microsoft Knowledge Base:
314852� How to enable Windows Installer logging in Windows XP

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Keywords: KB958049, kbprb, kbtshoot, kbpubtypekc

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Article Info
Article ID : 958049
Revision : 3
Created on : 4/20/2011
Published on : 4/20/2011
Exists online : False
Views : 562