Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: The cache is not updated when you use the SiteCacheRefresh method in the Commerce Server Starter Site if the Starter Site is running in IIS 7.0 integrated pipeline mode


View products that this article applies to.

Symptoms

When you try to refresh the site cache for the Starter Site or any customized site that is based on the Starter Site in Microsoft Commerce Server 2007, the site cache is not updated successfully. This problem occurs if the following conditions are true:
  • The site is running in Internet Information Services (IIS) 7.0 integrated pipeline mode.
  • You try to refresh the site either by using business management applications or directly by using a URL such as the following:
    http://Web_Server_Computer_Name/Site_Name/SiteCacheRefresh.axd?CacheToRefresh=CatalogCache
In the IIS log files, a "http status 302" message is associated with the SiteCacheRefresh.axd entry. Additionally, the redirect for the SiteCacheRefresh.axd file is set to the Login.aspx file.

Note By default, the IIS 7.0 log files are located in the following folder:
Drive: \inetpub\logs\LogFiles

↑ Back to the top


Cause

The issue occurs because of a problem in the CommerceComponent.dll file that the Starter Site package contains. The Starter Site is using mixed authentication modes. Specifically, the Starter Site is using Forms authentication for protected site pages such as checkout pages and Integrated Windows authentication for the SiteCacheRefresh method. However, IIS 7.0 integrated pipeline mode does not support mixed authentication modes.

↑ Back to the top


Resolution

To resolve this issue, install this hotfix, and then rebuild the site.

Note For any Commerce Server 2007 site that is using the CommerceComponent.dll file, you can change the code in the MixedAuthenticationModule.cs file in this fix and rebuild the site. The CommerceComponent.dll source code is included in the Starter Site download.

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Commerce Server 2007 and the Starter Site installed to apply this hotfix.

Restart requirement

You must restart IIS after you apply this hotfix. To restart IIS, open a command prompt, type iisreset /restart, and then press ENTER.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Commercecomponents.dll6.0.410 9.9189,46424-Sep- 200806:05x86
Mixedauthenticationmodule.csNot Applicable5,62919-Sep-200805:17Not Applicable

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

The latest version of the Starter Site is Commerce Server 2007 Starter Site R2. To download the Commerce Server 2007 Starter Site R2, visit the following Microsoft Web site: For more information about how to refresh the site cache, visit the following Microsoft Web site:

↑ Back to the top


Keywords: KB957935, kbsurveynew, kbqfe, kbexpertiseadvanced, kbexpertiseinter, kbautohotfix, kbhotfixserver

↑ Back to the top

Article Info
Article ID : 957935
Revision : 2
Created on : 3/5/2009
Published on : 3/5/2009
Exists online : False
Views : 364