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Windows Deployment Services fails to start in a disjoint namespace on a server that is running Windows Server 2003


View products that this article applies to.

Symptoms

You have a server that is running Windows Server 2003 in a disjoint namespace. However, you cannot start the Windows Deployment Services on this server.

When this issue occurs, the following event is added into the Application log:

Source: WDSServer
Date: <Date & time>
Event ID: 257
Task Category: WDSServer
Level: Error
Keywords: Classic
User: Not Applicable
Computer: <computer name>
Description: An error occurred while trying to start the Windows Deployment Services server. Error Information: 0x6E

Additionally, the following text is added into the Wdsmgmt.log file if you enable tracing on the Windows Deployment Services management components:
GetDSSServer: Domain=<domain name>
CLdap::Open: Server=<server name>, Port=389, DN=RootSDE
CLdap::Search2: BaseDN=, Filter=(objectClass=*), Scope=0
CWdsServer::NameInitialize(0x011CBEB0) =8007006e
CWdsServer::FinalRelease(0x011CBEB0)
CWdsServer::FinalRelease(0x011CBEB0) =0
CWdsManager::GetWdsServer(0x011C8C88) =8007006e
CWdsManager::FinalConstruct(0x002640C8)

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Cause

The Windows Deployment Services does not use the correct method to query the domain controller name that is in the disjoint namespace.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running Windows Server 2003 Service Pack 2 (SP2).

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
For all supported x86-based versions of Windows Server 2003 SP2
File nameFile versionFile sizeDateTimePlatform
Wdsmgmt.dll6.0.6000.16386569,34426-Jun-200905:55x86
For all supported x64-based versions of Windows Server 2003 SP2
File nameFile versionFile sizeDateTimePlatform
Wdsmgmt.dll6.0.6000.16386723,96826-Jun-200903:49x64

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Workaround

To work around the issue, move the current domain DNS suffix to the top of the DNS suffix list on the affected Windows Deployment Services server.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

To enable tracing on the Windows Deployment Services management components, follow these steps.

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Tracing\WDSMGMT
  3. Right-click EnableFileTracing, and then click Modify.
  4. In the Value data box, type 1, and then click OK.
  5. View the trace log for the Wdsmgmt.log file in the following location:
    %windir%\tracing\wdsmgmt.log
Note After you enable tracing, verify that the WDSServer service binds to the correct domain controller or to the correct global catalog server.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbexpertiseadvanced, kbfix, kbsurveynew, kbqfe, KB957918

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Article Info
Article ID : 957918
Revision : 2
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 220