Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Stop error on a Windows Server 2003-based terminal server that has hotfix 951749 installed: "0x0000008E"


View products that this article applies to.

Symptoms

A Windows Server 2003-based terminal server may restart unexpectedly when a client computer logs off from the terminal session. Additionally, you receive the following Stop error on the terminal server:
Stop code 0x0000008E
This issue occurs after you install hotfix 951749 on the terminal server.

↑ Back to the top


Cause

This issue occurs because Terminal Services tries to free user mode memory during the session cleanup process. However, the related process and the user mode memory do not exist. Therefore, stop error 0x0000008E occurs.

↑ Back to the top


Resolution

To resolve this issue, install hotfix 957877 on the terminal server. After you install this hotfix, Terminal Services frees user mode memory during the session cleanup process only when the memory exists.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, the computer must be running one of the following operating systens:
  • Windows Server 2003 with Service Pack 1 (SP1)
  • Windows Server 2003 with Service Pack 2 (SP2)

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with SP1, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Gdi32.dll5.2.3790.3091285,18418-Feb-200813:14x86SP1
Win32k.sys5.2.3790.32381,859,58431-Oct-200814:05x86SP1
Windows Server 2003 with SP2, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Win32k.sys5.2.3790.44011,849,85631-Oct-200816:13x86
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Gdi32.dll5.2.3790.3091619,00801-Nov-200800:42x64SP1Not Applicable
Win32k.sys5.2.3790.32384,549,63201-Nov-200800:43x64SP1Not Applicable
Wgdi32.dll5.2.3790.3091288,76801-Nov-200800:43x86SP1WOW
Windows Server 2003 with SP2, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Win32k.sys5.2.3790.44014,542,97601-Nov-200800:54x64
Windows Server 2003 with SP1, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Gdi32.dll5.2.3790.3091910,84801-Nov-200800:44IA-64SP1Not Applicable
Win32k.sys5.2.3790.32385,562,88001-Nov-200800:44IA-64SP1Not Applicable
Wgdi32.dll5.2.3790.3091288,76801-Nov-200800:44x86SP1WOW
Windows Server 2003 with SP2, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Win32k.sys5.2.3790.44015,568,51201-Nov-200800:53IA-64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about hotfix 951749, click the following article number to view the article in the Microsoft Knowledge Base:
951749 Stop error message on a terminal server that is running Windows Server 2003 Service Pack 1 or Windows Server 2003 Service Pack 2: "Stop 0x000000AB (SESSION_HAS_VALID_POOL_ON_EXIT)"
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbautohotfix, kbexpertiseadvanced, kbfix, kbqfe, KB957877

↑ Back to the top

Article Info
Article ID : 957877
Revision : 2
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 260