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The sequencing information is not exported when you export a virtual catalog from Commerce Server 2007 Catalog Manager


View products that this article applies to.

Symptoms

When you export a virtual catalog from Microsoft Commerce Server 2007 Catalog Manager, the sequencing information is not exported. If you use the resulting XML file to import the virtual catalog again, you have to sequence the products and the categories again.

Note Commerce Server lets you sequence the products and the categories, depending on your business needs. To do this, click Sequence Products and Categories in the Tasks pane in Catalog Manager.

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Cause

This problem occurs because of an issue in the stored procedure that handles the export of the sequencing information for the virtual catalog.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Commerce Server 2007 Service Pack 2 installed to apply this hotfix.

Restart requirement

You do not have to restart the computer. However, you must restart Internet Information Services (IIS) and the Commerce Server Catalog Import Host COM+ application after you apply this hotfix. To restart IIS, run the following command at a command prompt:
IISRESET /RESTART
Note This option stops and then restarts all IIS services that are running.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Catalogcreate.sqlNot applicable1,150,55506-Mar-200911:02Not applicable

Installation instructions

After you extract the hotfix package, you obtain the following files:
  • CommerceServer2007SP2-KB957596-ENU.exe
  • Ctlg_ExportHierarchy.sql
  • Hotfix.txt
Install the CommerceServer2007SP2-KB957596-ENU.exe file to update the Catalogcreate.sql file that makes sure that updated sequencing information in the virtual catalog can be exported for new catalog databases.

Additionally, run the Ctlg_ExportHierarchy.sql file against the existing catalog databases to update the stored procedure.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

In Catalog Manager, you can export the virtual catalog into an XML file. To do this, follow these steps:
  1. Select the virtual catalog.
  2. In the Tasks pane, click Export this Catalog.
  3. In the Export Product Catalog Wizard, click Next to move to the File Location page, click Advanced, specify the file location, and then click Next.
  4. On the Export properties page, click Export as virtual catalog, and then click Next to continue.
For more information about how to manage virtual catalogs, visit the following Microsoft Web site:For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: KB957596, kbqfe, kbfix, kbbug, kbsurveynew, kbexpertiseinter, kbautohotfix

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Article Info
Article ID : 957596
Revision : 2
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 372