Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: The IIS 7.0 performance counters stop updating after a Windows Vista system or a Windows Server 2008 system runs continuously for 30 to 45 days


View products that this article applies to.

Symptoms

After a Windows Vista system or a Windows Server 2008 system runs continuously for 30 to 45 days, the Microsoft Internet Information Services (IIS) 7.0 performance counters stop updating. Therefore, you cannot collect IIS 7.0 performance data by using Reliability and Performance Monitor. Additionally, an application event that resembles the following is logged in Event Viewer:

↑ Back to the top


Cause

This issue occurs because of an optimization logic that was introduced in IIS 7.0. This logic ignores the queued performance counter requests when the time stamps of the queued performance counter requests are smaller than the time stamps of the performance counter data in shared memory.

IIS 7.0 uses the GetTickCount Win32 API to obtain the time stamp values for both the queued performance counter requests and the performance counter data in the shared memory. These time stamp values are stored as DWORD values and are reset to zero if the system runs continuously for 49.7 days.

After the time stamp value of a request is reset to zero, the time stamp value of a request is always smaller than the time stamps in shared memory. Therefore, the request is ignored and the IIS performance counters stop updating.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.


Important Windows Vista and Windows Server 2008 hotfixes are included in the same packages. However, only one of these products may be listed on the “Hotfix Request” page. To request the hotfix package that applies to both Windows Vista and Windows Server 2008, just select the product that is listed on the page.

Prerequisites

You must have Windows Vista or Windows Server 2008 installed to apply this hotfix.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The global version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2008 and of Windows Vista, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Iisw3adm.dll7.0.6001.22258371,71205-Sep-200805:08x86
W3tp.dll7.0.6001.2225815,87205-Sep-200805:08x86
W3wphost.dll7.0.6001.2225846,59205-Sep-200805:08x86
Wbhstipm.dll7.0.6001.2225824,06405-Sep-200805:08x86
Wbhst_pm.dll7.0.6001.2225822,52805-Sep-200805:08x86
Windows Server 2008 and of Windows Vista, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Iisw3adm.dll7.0.6001.22258425,47205-Sep-200805:32x64
W3tp.dll7.0.6001.2225818,43205-Sep-200805:32x64
W3wphost.dll7.0.6001.2225850,17605-Sep-200805:32x64
Wbhstipm.dll7.0.6001.2225828,67205-Sep-200805:32x64
Wbhst_pm.dll7.0.6001.2225824,06405-Sep-200805:32x64
Windows Server 2008 and of Windows Vista, Itanium architecture versions
File nameFile versionFile sizeDateTimePlatform
Iisw3adm.dll7.0.6001.22258892,41605-Sep-200806:20IA-64
W3tp.dll7.0.6001.2225837,37605-Sep-200806:29IA-64
W3wphost.dll7.0.6001.22258117,76005-Sep-200806:29IA-64
Wbhstipm.dll7.0.6001.2225862,46405-Sep-200806:29IA-64
Wbhst_pm.dll7.0.6001.2225859,39205-Sep-200806:29IA-64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about IIS 7.0 performance counters, visit the following Microsoft Web site:For more information about the GetTickCount function, visit the following Microsoft Developer Network (MSDN) Web site:For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbautohotfix, kbsurveynew, kbqfe, kbhotfixserver, kb

↑ Back to the top

Article Info
Article ID : 957448
Revision : 5
Created on : 9/21/2018
Published on : 9/21/2018
Exists online : False
Views : 352