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The worker process for Exchange ActiveSync crashes when end-users try to synchronize their third-party devices with an Exchange Server 2003 server


View products that this article applies to.

Symptoms

On an Exchange Server 2003 server, the worker process for Exchange ActiveSync crashes when end-users try to synchronize their third-party devices with the Exchange Server 2003 server. Additionally, the following events are logged in the Application log:
Event Type: Error
Event Source: Application Error
Event ID: 1000
Description:
Faulting application w3wp.exe, version <version number>, faulting module MasSync.dll, version <version number>, fault address <address>.

Event Type: Warning
Event Source: W3SVC
Event ID: 1011
Description:
A process serving application pool 'ExchangeApplicationPool' suffered a fatal communication error with the World Wide Web Publishing Service. The process id was '<process ID>'. The data field contains the error number. 0000: 8007006d

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Cause

This issue occurs because of some messages in Japanese that are encoded in UTF-8. When this issue occurs, Exchange Server 2003 incorrectly calculates size of the message that causes an access violation.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

This hotfix requires Microsoft Exchange Server 2003 Service Pack 2 to be installed on the server because of file dependencies. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
836993 How to obtain the latest service packs for Exchange Server 2003

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTime
Massync.dll6.5.7654.7756,73608-Oct-200817:10

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: KB957191, kbqfe, kbhotfixserver, kbautohotfix, kbfix

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Article Info
Article ID : 957191
Revision : 1
Created on : 11/19/2008
Published on : 11/19/2008
Exists online : False
Views : 217