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When you start the Active Directory Users and Computers snap-in or the Active Directory Sites and Services snap-in on a Windows Server 2003-based computer, the snap-in closes unexpectedly the next time that you open it


View products that this article applies to.

Symptoms

Consider the following scenario:
  • On a Windows Server 2003-based computer, you open the Active Directory Users and Computers Microsoft Management Console (MMC) snap-in or the Active Directory Sites and Services MMC snap-in.
  • You expand the current domain, and then you click some sub-nodes in the console tree.
  • You click the Back button (the left arrow) on the toolbar.
In this scenario, all columns in the details pane except the Name column are missing.

When this problem occurs on a computer that is running an x64-based version of Windows Server 2003, the MMC snap-in closes unexpectedly (crashes) the next time that you open it.

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Cause

This problem occurs if the MMC configuration file for the MMC snap-in is corrupted.

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Resolution

Note If you experience the problem that is described in the "Symptoms" section, you must follow the steps in the "Workaround" section after you apply this hotfix.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 or Windows Server 2003 Service Pack 2 installed on the computer. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 1, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Dsadmin.dll5.2.3790.3195633,34420-Aug-200816:05x86
Windows Server 2003 with Service Pack 2, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Dsadmin.dll5.2.3790.4358633,34420-Aug-200816:19x86
Windows Server 2003 with Service Pack 1, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Dsadmin.dll5.2.3790.31951,976,32020-Aug-200814:00IA-64SP1Not Applicable
Wdsadmin.dll5.2.3790.3195633,34420-Aug-200814:00x86SP1WOW
Windows Server 2003 with Service Pack 2, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Dsadmin.dll5.2.3790.43581,976,32020-Aug-200814:04IA-64SP2Not Applicable
Wdsadmin.dll5.2.3790.4358633,34420-Aug-200814:04x86SP2WOW
Windows Server 2003 with Service Pack 1, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Dsadmin.dll5.2.3790.31951,115,13620-Aug-200814:00x64SP1Not Applicable
Wdsadmin.dll5.2.3790.3195633,34420-Aug-200814:00x86SP1WOW
Windows Server 2003 with Service Pack 2, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Dsadmin.dll5.2.3790.43581,115,13620-Aug-200814:06x64SP2Not Applicable
Wdsadmin.dll5.2.3790.4358633,34420-Aug-200814:06x86SP2WOW
Windows XP Professional x64 Edition with Service Pack 1
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Dsadmin.dll5.2.3790.31951,115,13620-Aug-200814:00x64SP1Not Applicable
Wdsadmin.dll5.2.3790.3195633,34420-Aug-200814:00x86SP1WOW
Windows XP Professional x64 Edition with Service Pack 2
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Dsadmin.dll5.2.3790.43581,115,13620-Aug-200814:06x64SP2Not Applicable
Wdsadmin.dll5.2.3790.4358633,34420-Aug-200814:06x86SP2WOW

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Workaround

To work around this problem, remove the corrupted MMC configuration file for the MMC snap-in.

The following file corresponds to the Active Directory Users and Computers MMC snap-in:
%AppData%\Microsoft\MMC\Dsa
The following file corresponds to the Active Directory Sites and Services MMC snap-in:
%AppData%\Microsoft\MMC\Dssite

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates


Technical support for x64-based versions of Microsoft Windows

If your hardware came with a Microsoft Windows x64 edition already installed, your hardware manufacturer provides technical support and assistance for the Windows x64 edition. In this case, your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation by using unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you must have technical help with a Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware. If you purchased a Windows x64 edition such as a Windows Server 2003 x64 edition separately, contact Microsoft for technical support.

For product information about Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about x64-based versions of Windows Server 2003, visit the following Microsoft Web site:

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Keywords: kbautohotfix, kbexpertiseinter, kbwinserv2003postsp2fix, kbbug, kbfix, kbqfe, KB956826

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Article Info
Article ID : 956826
Revision : 3
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 342